So I was trying to make renders for my game, and when I go to render the image or press F12, I get this.

enter image description here

When I choose render image or press F12 this happens. There is literally nothing in the render and it's just a grey screen. I thought maybe the render is just taking a long time to finish, So I started a 5 minute timer, the 5 minutes pass, and it's still the same grey screen.

Does anyone know how to fix this? I tried searching through tons of tutorials on YouTube, but I didn't find anything about this problem, So I have to rely on the Blender Stack Exchange.

Are there any settings I need to change? Any modifications needed in the camera properties or something? Is it about my GPU driver? I certainly hope not.

I really wanna fix this problem, because of this, I can't really do anything with Blender to make my game

Also, here's the .blend file:

  • $\begingroup$ Hello could you please share your file? Make it as simple and light as possible: blend-exchange.com $\endgroup$
    – moonboots
    Commented Jul 11, 2023 at 13:59
  • $\begingroup$ I added the file at the very bottom of the post. $\endgroup$ Commented Jul 11, 2023 at 14:10
  • $\begingroup$ make sure your camara is pointing at the object! $\endgroup$
    – ilayel201
    Commented Jul 11, 2023 at 14:18

1 Answer 1


The object called Cube.006 is hiding your scene but it's invisible for preview, make it invisible for render as well:

enter image description here

  • $\begingroup$ Oh wow! It's actually fixed, Thank you so much! Also if you are wondering why there aren't any textures, This is just the first asset for the game, and I am just using a render with no textures as a test/placeholder. $\endgroup$ Commented Jul 11, 2023 at 14:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .