2
$\begingroup$

today I wanted to add some edges to my model, but unfortunately the bevel tool doesn't bevel properly.

enter image description here

This is the result I get with it affecting edges only.

enter image description here

While this happens when I make it affect vertices only.

I have never had this issue before. I tried applying scale and rotation, but nothing seems to be fixing this.

$\endgroup$
0

2 Answers 2

4
$\begingroup$

Some of the face normals are inverted on your object. Check the Face Orientation option on the Viewport Overlays menu and faces with inverted normals will be shown in red.

enter image description here

Go into Edit mode, hit A to select all then Shift-N to recalculate the normals and your bevel tool will work correctly.

$\endgroup$
3
  • $\begingroup$ I've begun to adopt John Dickinson's habit of assigning pleasant modelling colours to the 'Face Orientation', and leaving it switched on all the time. $\endgroup$
    – Robin Betts
    Commented Jul 8, 2023 at 17:12
  • $\begingroup$ I've just stuck it on the Quick menu. That way you can instantly access it in either Object or Edit mode without having to search for it in different places on the overlay menu. $\endgroup$
    – John Eason
    Commented Jul 8, 2023 at 18:11
  • $\begingroup$ Yes. That's. Annoying. Trivial fix, almost worth an RCS. $\endgroup$
    – Robin Betts
    Commented Jul 8, 2023 at 18:36
1
$\begingroup$

It might be caused by not having applied scale, for example.

To apply the scale, choose your 3D object and press Ctrl + A, and click on Scale.

$\endgroup$
5
  • $\begingroup$ I tried applying the scale but the issue is still there. $\endgroup$
    – prox-ee
    Commented Jul 8, 2023 at 15:37
  • $\begingroup$ I have attached a photo with my Bevel settings. Perhaps you can try copying them and that way you might be able to see which setting was problematic. media.discordapp.net/attachments/996001987252469843/… $\endgroup$
    – Emo Ivanov
    Commented Jul 8, 2023 at 15:41
  • $\begingroup$ I tried copying the settings but unfortunately my issue was not fixed. $\endgroup$
    – prox-ee
    Commented Jul 8, 2023 at 15:44
  • $\begingroup$ Some of the faces of your object have inverted normals. Select All in Edit mode and Shift-N to recalculate them. $\endgroup$
    – John Eason
    Commented Jul 8, 2023 at 15:45
  • $\begingroup$ Oh that worked! Thanks. $\endgroup$
    – prox-ee
    Commented Jul 8, 2023 at 15:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .