0
$\begingroup$

I have a character and a piece of clothing (a jacket). I want the cloth to be partially controlled by the rig (area №1 in the picture) and partially simulated (2 in the picture). I am seeking a way to fix the explosion of the cloth.

enter image description here

I am following this tutorial (https://youtu.be/AbyfuW5Aocg Blender Tutorial - Cloth Simulation | Advance Simulation | Blender 2.9). I have paranted the jacket with automatic weights, set physics “cloth” to the jacket, and “collision” to my character’s body (mesh) and shirt (also a mesh). I have made the objects large and applied scale. I tried selecting my collection in “collision collection”. I have played with other settings, I have brought quality steps up and collision distance down. But the jacket keeps exploding. Deleting armature modifiers on cloth does not help. I have also made sure that cloth modifier is the las and armature is the first. I have added pin group for the vertices in areae 1.

enter image description here

I have also tried using the same settings with subdivided plane (as cloth) and a sphere (collision object) and it works fine. enter image description here

Could you please tell me how to prevent cloth jacket from exploding while keeping it controlled both by simulaion and an armature? I will be grateful for any help I am using Blender 3.3.0 File is too big to upload it through blend-exchange Link to my file (new) https://cloud.mail.ru/public/Rjns/RHXCmMLhz

$\endgroup$
2
  • $\begingroup$ You made a few little mistakes here and there that sums up. I'm going to write an answer on how to fix it. But meanwhile, I have to ask: what are these spiky things on the left and right shoulder of the creature? $\endgroup$
    – Blunder
    Commented Jul 8, 2023 at 14:37
  • $\begingroup$ @Blunder , Hello! Thank you for volunteering to help me. I am looking forward to your message! Those "spiky things" are the flesh of the wings. I want to make my character's wings look as light as possible, so I made the flesh part really thin. I had big and small feathers attached to the wings' flesh, but I deleted them in order to make my file smaller and easier to share $\endgroup$
    – ksenya
    Commented Jul 8, 2023 at 16:30

1 Answer 1

0
$\begingroup$

If the cloth simulation "explodes" the reason is often the collision detection. It also does not like duplicated vertices. There are also a few other things you should fix first.

The jacket is low-poly (~2000 verts) but it has some high-poly seams on it (~70,000 verts). In combination with a level 3 Subdivision Surface modifier, this will create around 4,000,000 vertices. That's too many. Let's fix the jacket:

  1. So in the first step, I would separate the seams from the jacket. You can select the linked vertices. Just select one, hover the mouse over the seam, and press L to select them all. Then you can separate the seams into their own object (P > Selected).

  2. The jacket also has 23 duplicated vertices that you should remove. Select everything (A) in Edit mode, then press M > Merge by Distance to get rid of them.

  3. The jacket has more edge loops at the bottom (belly area) and a "gap" in the middle. The cloth simulation will work better if the faces have an equal size. So select a few edge loops (Alt+click) and dissolve (X) them. You also can slide them with GG when you have selected the loop.

Done this you should clean up the modifiers stack and remove the red Armature modifiers if you don't need them. Then move the Subdivision Surface modifier down, and set the levels to 1. This should do the trick. It will smooth the model. The around 2000 vertices of the base mesh are enough for the simulation. screenshot 1

Now you can define a vertex group "Pin" as shown in the tutorial video. Go to the Weight Paint mode and paint the jacket red (weight = 1) where you want the armature to deform the object. The blue areas are deformed by the cloth simulation. screenshot 2

Specify the "Pin" group in the cloth settings. Here you can also adjust the Collision Distance. Your model is 32 meters tall (scaled up by 10), and you have specified 1 mm here. This is too close and can make the collision detection freak out (explosion!). Better use 1cm (0.01 m) or even 10cm (0.1 m) to prevent "Z-fighting" when you zoom out. screenshot 3

Now the cloth simulation should run smoothly and perform well. There is still some "Z-fighting" as you can see in the example at the inner leg and the side. This is because the model is huge and you have to zoom out about 100 meters. To prevent this

  1. you can increase the gap between the body and the cloth layers (Collision Distance values). The Collision modifier has also a few settings for this.
  2. Or use a Mask modifier to hide the underlying meshes.
  3. Or try the cloth simulation at normal size. You need to adjust the values for the collision distances and maybe the value Cloth >Physical Properties > Vertex Mass to get the same result at a smaller size.

example cloth simulation

$\endgroup$
1
  • $\begingroup$ Thank you so much! $\endgroup$
    – ksenya
    Commented Jul 18, 2023 at 19:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .