1
$\begingroup$

I have made an animated exhaust flame for my project, using a displace modifier on a cylinder and a gradient texture, color ramp, emission & transparent bsdf connected in the shader nodes. Im rendering in Cycles.

What I want is for the exhaust flame to fade out when the vehicle is coming to a stop. What im having trouble with, is that I cant get the exhaust flame to become completely transparent without having to keyframe the visibility. I want it to fade out in a smooth animation. This last part works fine, by adjusting the colorramp thats connected to the fac of the transparent node. However, the displaced object is still visible. Only the colors fade out, and then its just lightly transparent but black.

Might be worth noting: There are 2 seperate flames inside eachother, a bigger one and a smaller one. Not sure if this has anything to do with it.

What I have tried:

  • Changed blend modes from Opaque to Alpha Blend as well as all the other options
  • Enabling/disabling Blackface Culling
  • Pair emission and transparent nodes into Mix shader
  • Adjust the colorramp values (only fades out the color)
  • Replaced emission shader with principled bsdf, connected the texture to emission in principled bsdf, adjusted the alpha value. There is no difference to be seen in the result
  • Increased Light Bounces from 4 to 8 and Transparency all the way to 50 and above

When I keyframe the visibility right after the moment the colored flame faded out, you can see the silhouette before it abruptly becomes invisible. So thats why Im hoping theres a way to make it completely transparent so i can keep the smooth fade-out.

Picture of my node setup:

Light Bounces settings:

Blend settings:

Image of the flames when emission is active

The flame fades out like intended, however, it just becomes black as you can see

Another image of the fade. If i keyframe the visibility when the color has faded out, it looks so ugly and highly unprofessional

Rendered image of when the flame is supposed to be completely transparent, but is not

So, does anyone know how I can animate the emission to fade out until it becomes completely transparent instead of black?

Any help is appreciated. Thank you.

$\endgroup$

1 Answer 1

1
$\begingroup$

The Alpha-related parameters in the material's setting only affect how transparency is interpreted by Eevee, it does not determine the actual alpha of your shaders.
If you were using Eevee or the material view, you'd need to set the Blend and Shadow modes to Alpha Blend in order to be able to see transparency on that material. But again: this isn't what determines the transparency in your shader, it just changes how it is interpreted in that renderer.


What you need it to add a Mix shader at the end of your shader tree, just before the Material Output node.

Plug your first Mix Shader's output into the new Mix Shader's first shader output. Then add a Transparent BSDF node, plug it to the second shader input of the new Mix Shader.

Set that Mix Shader's factor to 0 to show only its first input, and to 1 to show only the second input. Second input is fully transparent, so it should be transparent.

enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ Wow I can not thank you enough! It worked. Thank you! I was stuck for almost a week. You have no idea how much youve helped me get back on track. Thank you very much! $\endgroup$
    – Slice Dice
    Jul 7, 2023 at 14:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .