0
$\begingroup$

When I'm painting (in 3.6), the colour works fine until I add the texture, then the colour changes to black no matter what I pick. If I disable the texture, it goes back to painting in my selected colour, but then I can't use the texture.

I couldn't find anything on google except for this and this, and those solutions didn't work for me.

Texture Paint Settings

I also tried enabling and disabling a whole bunch of random options, and it didn't change anything.

Texture Settings

$\endgroup$
1
  • $\begingroup$ Note: it only happens with custom image textures, if I use the built in ones like clouds, it works fine. $\endgroup$
    – Tobin
    Jul 6, 2023 at 14:52

1 Answer 1

0
$\begingroup$

I figured it out, I was using a png image for my brush, which Blender doesn't like for some reason. Instead I had to change the brush image to white, and put it on a black background, then it started working fine with colours.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .