1
$\begingroup$

I'm in Texture Painting mode and every time I hit ctrl-z or open the file the brush is changed from draw to smear.

I don't think it's a shortcut issue, I've checked the shortcuts and neither z or control are mentioned in the list.

Every time I switch to the texture painting workspace the tool is also switched to smear.

enter image description here

$\endgroup$

1 Answer 1

0
$\begingroup$

I found an answer on an old blender bug report! https://projects.blender.org/blender/blender/issues/94749

Apparently my problem was related to a really old bug that has to do with working on two monitors. The author of the initial bug report left a detailed process on how to replicate and fix the bug:

Exact steps for others to reproduce the error

- File > Defaults > Load Factory Settings
- Window > New Main Window
- On the New Main Window, select the UV Editing workspace
- Combine the two main areas so only the UV Editor area remains, covering most of the workspace, and the 3D Viewport area is removed
- On the original Main Window, select the Sculpting workspace
- Select the Grab brush
- Make three brushstrokes
- Press undo once

Observe as one brushstroke is removed as expected but the brush type is also changed back to the default Draw brush

Additional observation:

- Close the New Main Window that has the UV Editor open
- On the original Main Window, select the Sculpting (Texture Painting here) workspace
- Select the Grab brush
- Make three brushstrokes
- Press undo once
- Observe as one brushstroke is removed as expected and the brush type does not change

I left my own bug report linked to his: https://projects.blender.org/blender/blender/issues/109762

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .