5
$\begingroup$

I'm working with a relatively detailed model, which some some inner detail. At the moment I am not concerned with the inner faces, I would just like to select the outer faces so that I can apply a material to them. However, whenever I try using the Face selection options I often end up selecting an interior Face rather than the external Face I'm looking for.


Are those faces on top I've selected?


Nope.

Is there any way I can use the Face selection tools to target the closest faces that intersect the point I click, rather than whatever the default behaviour is which typically catches these internal faces?

I've been trying with both the current Blender 2.68 and the older 2.49b.

$\endgroup$
4
$\begingroup$

Unless I'm missing something isn't this just because you are in wireframe view mode?

Press Z to go into solid view then make sure Limit Selection to Visible is enabled in the 3D view header as shown below:

enter image description here

Now your model will appear solid and you will be able to select whichever face is directly visible to you in the view i.e. you won't be able to select faces that are behind other faces.

$\endgroup$
  • $\begingroup$ That did it - thanks! (I'm obvious not very familiar with the interface yet. :P) $\endgroup$ – ON STRIKE - Jeremy Banks Sep 17 '13 at 18:04
  • $\begingroup$ That'll come in time. Don't worry. Although this button can be a real pain sometimes (: $\endgroup$ – Haunt_House Sep 17 '13 at 19:42
3
$\begingroup$

  One additional thing you can do is to select the inner verts and hide them. H hides selected verts, ShiftH hides unselected verts and AltH reveals all hidden verts. If inner and outer verts are connected, you can, if your topology allows it, use a Loop Select AltRMB and once the loop is hidden and the inner mesh is disconnected, select it with L.

  You can also use AltB to hide part of everything, the Mask Modifier or, if the inner mesh is completely separate, you can make it a separate mesh by selecting it in Edit Mode and pressing P and join them later in Object mode by selecting both and pressing CtrlJ.

  This can be an alternative to Limit selection to visible because sometimes the outer surface isn't entirely convex and overlaps. Then this setting will cause you to miss verts. Sometimes you want to select the rear verts of the outside surface as well. And sometimes you want to see the wireframe of your model, where this option doesn't exist.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.