0
$\begingroup$

I have this beautiful Lamborghini Urraco model but unfortunately I can't seem to fix this bad shading on this triangulated door mesh, it's very hard to see in Blender but it's quite eye-staggering when exported into a game: enter image description here

The mesh with the wireframe: enter image description here

I've been trying to reduce Auto Smooth but I can't go any lower before the mesh gets like it is without Auto Smooth. I also tried to apply sharp edges and replacing triangles but it still looks bad unfortunately.

Here is the .blend file of the mesh if you want to take a look.

P.S. I would like to keep it triangulated because the game automatically converts quads into triangles.

Thanks in advance for your help!

$\endgroup$
2
  • $\begingroup$ The topology in your blend file looks pretty good, so it may be an issue in the game engine. Can you disable the environment mapping in the game and see if the bad shading persists? $\endgroup$
    – taiyo
    Commented Jun 29, 2023 at 8:16
  • $\begingroup$ Yes I disabled AO and such shadow effects and it still looks wrong, and even after generating the AO for the car chassis I can't reproduce the same shading problem in Blender so this must be a game problem indeed, thanks! $\endgroup$ Commented Jul 1, 2023 at 8:04

1 Answer 1

0
$\begingroup$

Try recalculating normals ⇧ Shift + N

Also remove any double vertices Edit Mode with M > Remove Doubles and delete any inside faces.

$\endgroup$
1
  • $\begingroup$ I of course did that several times to make sure but unfortunately it still looks the same, even though the shading looks almost perfect in Blender... $\endgroup$ Commented Jun 29, 2023 at 7:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .