1
$\begingroup$

I have an emissive texture up against a wall. it's just a flat plane with a color set to the emission channel. At some distance, there is a sharp shadow line on the wall—but I don't see how it's physically possible for this shadow to be occurring, the line runs parallel to the light source all the way through the frame, and I'm wondering if it's some kind of render setting. Bad shadow.jpg

It seems like it's not actually a shadow line, because it doesn't show up on surfaces within this distance. It's like some kind of force field that changes the light beyond a certain distance.

I tested this by adding some cubes around the line to see how the transition line fell. weird shadows

What could be doing this? A bit new to things here.

$\endgroup$
3
  • 3
    $\begingroup$ From these screenshots it is not entirely clear what the problem is, insert a blend file by following the instructions on blend-exchange.com , if you can. $\endgroup$
    – Zyzio
    Jun 21, 2023 at 6:39
  • $\begingroup$ your blend file will be more useful, my current guess is Z clipping, you have 2 faces at the exact same height, they overlap each other and make pure black square in place where they overlap $\endgroup$
    – MikoCG
    Jun 21, 2023 at 8:04
  • $\begingroup$ How is the "shadow line" affected if you rotate or move or scale the emmissive object? $\endgroup$ Aug 9, 2023 at 23:12

2 Answers 2

0
$\begingroup$

Did you check that your emissive plane is not clipping (or touching) through the wall?

Move it away from the wall a bit.

$\endgroup$
-1
$\begingroup$

The answer is that this is a bug within Blender. If you go to the Material properties of the emissive material, and go to Settings -> Surface -> Emission Sampling and set it to none, the problem goes away.

$\endgroup$
1
  • $\begingroup$ I don't think this fully answers the question. Switching the Emission Sampling to 'none' breaks the render as the emission surface will no longer contribute to the scene. There isn't enough information in the question to replicate the issue so as it stands this can't be raised as a bug. You should create a test case that's sufficiently detailed to submit as a bug report. I suspect that this is probably an artefact of the emission sampling but it's possibly a limitation that's made more prominent by the situation - rather than a bug (similar to the terminator problem). $\endgroup$ Nov 14, 2023 at 0:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .