0
$\begingroup$

I followed many tutorials on how to create hair in blender with the new geometry nodes system.

At first when I create my first strands, their radius is way thiner than the ones everyone is supposed to.

Basic hair strands with default geo node setup

And when I try to change the radius nothing happens.

Just added a bigger curve radius

I tried other nodes in order to see if the problem was coming from my node tree, but it seems not

Other node setup

I also tried the "Set Hair Curve Profile" node which neither has an effect.

It is the first time in my 2 years of learning blender that I got really blocked without finding an already existing solution.

Thanks a lot for your help, hope any of you could do something

EDIT_1 : I created this same node system on 3 different computers, they all have the same problem. Is there a prerequisite or a button I did not checked ? Don't hesitate to try the simple node tree on your own computer

EDIT_2 : I still can make a geo node group at the end to convert my hair to mesh and change the radius of my profile curve circle. But I loose all the interest of working with curves and my computer bercomes really laggy

$\endgroup$
4
  • $\begingroup$ From my experience (using the interface particle hair system) changing the root and tip radius affects the simulation, and perhaps the rendering, but you won't see the radius in the 3D view. Do you see a radius change in the tutorials? $\endgroup$
    – james_t
    Jun 18, 2023 at 15:36
  • $\begingroup$ Yes, normally it is supposed to change the radius in real time but it doesn't in mine even in rendered view. I still can convert my curves to mesh and change the radius of the circular curve profile but it costs me a lot of ressources. It is not supposed to work like that. $\endgroup$
    – Bay
    Jun 18, 2023 at 16:40
  • $\begingroup$ Have you set Curves > Shape to Strip in the Eevee settings? (or Curves > Viewport Display > Shape for Cycles) $\endgroup$
    – Blunder
    Jun 19, 2023 at 8:59
  • $\begingroup$ Yes, you can look under "shmuel" answer $\endgroup$
    – Bay
    Jun 19, 2023 at 10:02

1 Answer 1

1
$\begingroup$

you have to change the viewport render settings from strand to strip.

it's in the render settings (same place where you set the noise threshold, denoising, l8ght bounces etc.) under viewport.

$\endgroup$
3
  • $\begingroup$ I tried to change the viewport render settings from strand to strip and the change is indeed visible. However when I render my modifications are not applied, thanks for your answer $\endgroup$
    – Bay
    Jun 19, 2023 at 9:36
  • $\begingroup$ There is a limitation if you join another bezier curve object with the curves. Depending on the order of the joined geometry the radius can be messed up. See #99786 But your first simple example works for me in Blender 3.5, in the viewport and rendered with Eevee. $\endgroup$
    – Blunder
    Jun 19, 2023 at 22:01
  • $\begingroup$ Ok It indeed worked. I thought I already tried the option once. Isn't it weird that it is labeled as a "viewport display setting" ? Thank's for all, it also works in cycles. You helped a lot $\endgroup$
    – Bay
    Jun 20, 2023 at 9:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .