2
$\begingroup$

Having a bit of panic! I’m in a pinch working to finish an urgent university assignment (short animated film).

Rendering with Cycles I just noticed a weird glitch that occurs only on specific frames! It appears like colored rays of light bouncing from parts of my mesh…

Does anyone recognize this phenomenon and how can I fix this?!?

Here’s frame 0626 which has the glitch:

enter image description here

Here's frame 0627 which doesn't have the glitch (I estimate about 2/10 frames has the glitch):

enter image description here

Here's frame 0626 without the glitch in EEVEE, which suggests this is a Cycles issue:

enter image description here


If someone's willing to have a look, here’s the .blend file (link expires July 17). Try render frame 0626 and see if you got the same glitch: https://www.swisstransfer.com/d/048f4b7a-a59d-471c-9a2c-a5b47b41be6b 1 (link expires July 17)

I’m on Blender 3.5.1 / Windows 11 22H2. Got the same result with vanilla 3.5.1 portable. Curious if it’s my system or not.

$\endgroup$
1
  • 1
    $\begingroup$ The problem might be with animation. I suspect something changes really fast in between frames and is rendered as motion blur, because if you disable motion blur, the problem disappears. Or it could be some other glitch with motion blur. $\endgroup$ Jun 17, 2023 at 9:23

1 Answer 1

4
$\begingroup$

It seems Preserve Volume feature on the rig is causing problems together with motion blur. It probably briefly moves some geometry in between frames and this glitch causes motion blur to render it. Disabling Preserve Volume solves the issue, but as I am not very familiar with animation, I don't really know what issues you might have because of disabling it - as far as I understand the feature is sort of important for more realistic deformations.

enter image description here

The glitch itself looks visually similar to problems with weights, so you could check that. I don't ever work with animations, so I am no expert here, but weights don't seem to look like they are OK. For example this is probably not right for vertex group named "neck.x":

enter image description here

So based in this I am guessing there might be other problems with weights and I think it is likely that might have something to do with the problem.

$\endgroup$
4
  • $\begingroup$ You are a rock. Disabling "Preserve Volume" saved my day. Interesting about motion blur. Apparently, it also works by selecting the character mesh object, then Object Properties > and turning off Motion Blur. According to someone on Discord, the culprit can be Auto Smooth, which might freak out in cases like these (and when Motion Blur is turned on). $\endgroup$
    – Henrik
    Jun 17, 2023 at 18:49
  • $\begingroup$ I don't know what it is for sure, but it doesn't seem like auto-smooth could be the issue. It seems like something is moving in space, not on the surface. $\endgroup$ Jun 17, 2023 at 19:41
  • $\begingroup$ I agree, but for some odd reason, turning off Auto Smooth does actually remove the glitch. In a nutshell, either of these methods will remedy the glitch: - Turn off Motion Blur - Turn off Preserve Volume - Turn off Auto-Smooth I think I went with the latter (Auto-Smooth) because my character doesn't have many sharp edges. I'm leaving this comment here for people crossing roads with this same issue as I did. $\endgroup$
    – Henrik
    Jun 24, 2023 at 7:46
  • $\begingroup$ I suspect fixing weights might resolve the actual issue so no features would need to be turned off. $\endgroup$ Jun 24, 2023 at 8:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .