0
$\begingroup$

I'm running Blender on Arch Linux with an AMD Radeon RX 7900 XT and the latest drivers and for some reason Blender is unable to detect my GPU as being compatible with HIP. As far as I am aware, my GPU should be more than compatible with the specifications required of me. I've attached a screenshot of the screen to show what I mean. Cycles Renderer Image

$\endgroup$
3
  • $\begingroup$ If your drivers are up to date and you're using the latest version of both Blender and your version of Linux, you should report it as a bug via Help > report a Bug as there are no developers here who can help you. $\endgroup$
    – John Eason
    Jun 13, 2023 at 18:55
  • $\begingroup$ Just to rule out a few silly mistakes, have you connected your monitor to the GPU's and not to the mainboard's HDMI/display port? Are you sure the system uses the graphics card and not the integrated GPU? askubuntu.com/questions/5417/how-to-get-the-gpu-info or baeldung.com/linux/check-monitor-active-gpu $\endgroup$
    – Blunder
    Jun 13, 2023 at 19:34
  • $\begingroup$ My graphics card should fine since I don't have an integrated GPU set up on this desktop and the graphics card works just fine when doing something else on the system like playing a game or what have you. I'm going to report this bug and see what comes of it $\endgroup$
    – Doozku
    Jun 13, 2023 at 19:57

2 Answers 2

1
$\begingroup$

So I figured out what the problem is. I'm using Arch Linux and I didn't realize that I needed a specific package called 'hip-runtime-amd' in order to properly run the Cycles renderer on my OS. After installing that package it works like a charm!

$\endgroup$
1
  • 1
    $\begingroup$ What would the Ubuntu equivalent be? $\endgroup$
    – J-Cake
    Oct 2, 2023 at 21:52
0
$\begingroup$

ran into the same issue with a new NVIDIA gpu and I think this might be a bug now that I'm seeing your question from the AMD side (and after trying basically everything possible in my case for a few days now that others online with the same issue did). Bugs should be reported...but in the off chance for you this isn't a bug here are some things that were suggested online while trying to fix my issue with this that worked for a few others that might help you:

  • reset BIOS with the new GPU (pretend you're starting from scratch) and make sure BIOS is up to date
  • make sure windows is up to date
  • do a clean reinstall of blender (delete all versions in the cache folder and use something like revo uninstaller to make sure it's all gone)
  • do a clean reinstall of your gpu drivers and make sure you're using the "studio driver" instead of the "games driver" (whatever AMD's equivalent is: this link I found is from 2021 but looks helpful for you)
  • go into AMD's control panel (Radeon settings) and make sure everything is set to compatible (for NVIDIA you go to NVIDIA control panel and set to a blender [vs global settings] and make sure the options are a little more 3d frinedly)
  • make sure in device manager you have no gpu errors/events (you might have a migration error if it's a new install, but this is fixed by resetting BIOS usually)
  • as others have said, do a benchmark test or test your gpu function on another program that's GPU heavy such as Premiere or After Effects.

if all that fails it's safe to assume it's a blender issue, not a hardware issue. Same boat as you, thanks for posting this regardless so others with new GPUs can see it might be a bug, there wasn't much online when searching this for myself.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .