0
$\begingroup$

I'm using Cycles as my render engine, on the latest version of Blender 3.5.1

In compositor, I used a set of nodes to seperate the highlights (glossy) from the rest in order to save it seperately in a .png file. Nodes used to output the highlights

Set alpha Node for transparency, Mix/Math node with add method to get both direct and indirect glossiness, Denoise to get a clean looking result.

Issue : after rendering, I display the result (Viewer node) and it looks perfect, no noise, no issues, and it has transparency How the highlights look like after rendering

But when I save it as .png, the image is noisy Image opened in default windows Photos viewer

What am I doing wrong ?

$\endgroup$
1
  • $\begingroup$ Please upload your file on Blend-Exchange, and edit your post to include the download link, so that we can search ourselves. $\endgroup$
    – Lauloque
    Commented Jun 13, 2023 at 13:18

1 Answer 1

0
$\begingroup$

In your screenshot, you show that you plugged your denoised glossy pass into a viewer node, but not into a Composite.

The Composite is the final output that gets visible as "Render Result" in the image editor and gets saved into files. The viewer node is only a temporary preview for work purposes only.

Plug your denoised glossy into the Composite node, and it should work.

$\endgroup$
1
  • $\begingroup$ Hello, My composite node's input is the beauty pass (Image) from Render Layers, even with what you have suggested, it still is noisy after saving. I should specify that all my other results that I have saved as .png from viewer node are not noisy, the only noisy result is the glossy one. $\endgroup$
    – art_stuff
    Commented Jun 13, 2023 at 7:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .