0
$\begingroup$

I'm baffled about this issue I've recetly been having. So I have made a bunch of rooms in blender and all of them have a really big plane set up over them, with tiles, and some of those tiles emitting light. However when I render it in cycles, and this only happens in cycles render, not in viewport shading, as that is fine for some reasons, but when I render, all my rooms are completely dark, like the lights are'nt one except these four lights, I have no clue why..

So here's it in the viewportenter image description here

and here it is in the actual render, I really don't understand why all but those four lights inside the room with the wood flooring are only on... enter image description here

Here's a top down view. enter image description here

And a ss of the material for the light, enter image description here

$\endgroup$
4
  • $\begingroup$ Hello, maybe you have overlapping faces? (Z fighting) $\endgroup$
    – moonboots
    Commented Jun 12, 2023 at 15:36
  • $\begingroup$ How would I remove that? $\endgroup$ Commented Jun 12, 2023 at 15:37
  • 1
    $\begingroup$ AHAH IT WAS THAT, THANK YOU!!!! $\endgroup$ Commented Jun 12, 2023 at 15:39
  • $\begingroup$ Hello and welcome. Please don't write in all caps in the title or body of any posts, it is the written equivalent of shouting, is harder to read and may be considered rude. Please use the edit button below the post to change you text into regular case. $\endgroup$ Commented Jun 12, 2023 at 15:40

1 Answer 1

1
$\begingroup$

you have overlapping faces, it's called Z fighting and it makes materials go black in Cycles, you need to switch to Edit mode, select all and press M > Merge by Distance.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .