2
$\begingroup$

I have a metal stripe wrapped around both the blue object and the pink object, and they both have the same material applied to them. The reflections/lighting on the blue object stripe appear rounded even if the surface is flat.

Enter image description here

Modifiers applied to stripe on blue object are unknown. Presumably the same modifiers shown below are applied, and I tried applying them on the pink object, but results differ.

Modifiers on pink object stripe

The cycles rendered image is below.

Enter image description here

I am not sure if it's a lighting option or a modifier, but I'd like to get the same curved lighting on the pink object's stripe. How would I do that?

$\endgroup$
5
  • $\begingroup$ Hello, are you sure that the metal stripe is not curvy? Please share your file: blend-exchange.com $\endgroup$
    – moonboots
    Jun 8, 2023 at 6:30
  • 1
    $\begingroup$ @moonboots It's just Auto Smooth enabled vs. disabled. $\endgroup$ Jun 8, 2023 at 6:45
  • $\begingroup$ Oh OK you must be right $\endgroup$
    – moonboots
    Jun 8, 2023 at 6:50
  • $\begingroup$ @moonboots Actually I included the possibility of a rounded object into my answer as well (since "smooth" looks much more curvy in my example) because the question says, there are unknown modifiers applied to the curvy stripe. But to be honest, I would expect the minimum effort of a user who has the file to simply go into Edit Mode or maybe choose something less deceiving like Solid shading to just look at the mesh if there is a difference in curving - so I went for the smoothing variant first. $\endgroup$ Jun 8, 2023 at 7:10
  • $\begingroup$ My goal was to create a rounded metal band to wrap around the objects, the simplest solution to reach that look in the other object was, stupidly enough, autosmooth and/or subsurf. Admitting I still have limited experience, there were definitely other, possibly better methods to reach the results I wanted! $\endgroup$
    – Shadows
    Jun 8, 2023 at 23:53

3 Answers 3

4
$\begingroup$

If the metal band has to be flat, and you want it to shade round, then you'll have to mess with the normals, one way or another.

Here, that's done with a Data Transfer modifier.

  • The (blue) target is a loop stolen from the original model, converted to a curve, bevelled 'Round' in its Data > Geometry panel, and converted back to a mesh
  • The transfer modifier is aimed at a vertex-group comprising the metallic element of the model:

enter image description here

This isn't the only way.. you could use a bump-map in the metal material. That raises the question of how you'd like to map it. In turn, that would depend on whether the band is a separate object, or a separated surface.. we need a bit more information. There looks as if there's a very slight contact shadow from the band in your reference? That suggests it's a separate surface.

There is already enough topology in the model to AltS fatten the central loop to round the band in actual geometry, though. That would seem preferable.

$\endgroup$
4
$\begingroup$

Without examining the objects it is not so easy to say, but my first guess would be, the "flat" stripe is set to Shade Auto Smooth (or Auto Smooth enabled afterwards), while the "curvy" stripe is set to Shade Smooth i.e. Auto Smooth not enabled. If this is not the solution, I guess on the "curvy" stripe the Subdivision Surface modifier was placed after the Solidify modifier.

Here is an example for the Auto Smooth option, I've recreated the shapes:

auto smooth vs smooth

To get the same look for the left one, either select it, then right-click in the viewport and choose Shade Smooth or go to the Object Data Properties and disable Normals > Auto Smooth there:

auto smooth disabled

The Auto Smooth option lets you set an angle (30° by default) above which an edge is considered sharp and will not be shaped smooth anymore. So the top and bottom rim with 90° angles are sharp. If Auto Smooth is disabled, the shading of everything will be smoothed out, even the 90° angles on the border, that's why it looks rounded. This also means, if the stripes were flat and had no thickness, they would both look the same (flat), because then there would be no 90° angle over which the smooth shading would be extended.

And here is the option with the different order of modifiers. On the right you have a thinner light reflection than in the previous example, so maybe this is what happened there:

modifier order

$\endgroup$
1
  • $\begingroup$ Enabling autosmooth was indeed the simplest solution, quite a novice oversight on my part. On the other hand, I noticed differences in the mesh and thought of subdividing more, but I was applying modifiers wrongly and were getting weird results, after trying the right order I got satisfying results. Thank you for the detailed help! $\endgroup$
    – Shadows
    Jun 8, 2023 at 23:23
2
$\begingroup$

I didn't get it perfectly the same as with solidify, but here's a solution using a shader:

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .