2
$\begingroup$

I’ve looked all over the internet trying to find the solution to my problem.

i’m trying to transfer high poly details onto a low poly mesh using the cage method

However, the final mesh, after i plug the image texture into the normal map, comes out in patches.

Any solutions? Recommendations?

I linked the file below

Packed Files

enter image description here

enter image description here

$\endgroup$
15
  • $\begingroup$ Hello and welcome. Rather than take photos of your monitor post actual screenshots instead, see How to take a screenshot. Photos are harder to read because we have to look past external interferences (like reflections, smudges or Moiré patterns) and guess if we are looking at hardware issues such as a malfunctioning display or connections, a software level issue like driver malfunction or glitch, or actual artifacts or issues with the model itself. $\endgroup$ Jun 7, 2023 at 16:47
  • $\begingroup$ The Image Texture needs to be set to Non-Color, not sRGB, maybe it will fix your problem, or please pack your images and share your file $\endgroup$
    – moonboots
    Jun 7, 2023 at 16:50
  • $\begingroup$ @moonboots doesnt seem to work, just turned the mesh black. $\endgroup$ Jun 7, 2023 at 17:00
  • $\begingroup$ please pack the images and share your file $\endgroup$
    – moonboots
    Jun 7, 2023 at 17:01
  • 1
    $\begingroup$ So using my same settings that i posted, the only difference i would need to make would be checking the 32-float option? $\endgroup$ Jun 7, 2023 at 19:28

2 Answers 2

1
$\begingroup$

It looks like it's just a problem of image settings, it needs to be 32-Bit Float, otherwise you'll have this kind of artefacts:

enter image description here

$\endgroup$
2
  • $\begingroup$ Congratulation :) Works for me ... I just smell there is something more behind it. We got an issue when saved to 32bit OpenEXR and was fine when saved to 16bit. So you should probably sync bit depth in all this process like if you start with 16bit image you should save as 16bit ... iy you start with 32bit like you recommend now saving to 32bit fits ... or so ... I'm tired to think now :) $\endgroup$
    – vklidu
    Jun 7, 2023 at 19:41
  • $\begingroup$ I'm not very good with all these technical things, I know it's better to have a 32-Bit Float for normal maps :/ $\endgroup$
    – moonboots
    Jun 7, 2023 at 19:54
0
$\begingroup$

My conclusion on given question is like this ...


The simplest part :)

Your "patches" are caused by Image texture's Color Space set to sRGB, the baked colours are interpreted in a wrong way...

Left-Lowpoly (Baked), Right-HighPoly enter image description here

... when color space is set to Non-Color the issue is gone.

Left-Lowpoly (Baked), Right-HighPoly enter image description here

Than saving into some format supporting 32bit dept is the best option to operate with enough colours to render smooth surface.

Circumstances

Your shared file is using Image texture > Generated without more info, but yesterday testing lead me to think it is a 16 bit depth only.

So when baked normals are saved into PNG format (means 16bit max) it works fine, but when you try to save this bake into OpenEXR (Full-FLoat = 32bit) it fails into "patches" again.

To get 32bit texture you have to enable Float Buffer under properties ...

enter image description here (... or add a new Image texture > Generated with 32bit enabled as suggested by moonboots in his answer.)

Notes:

  • Part of the mishmash in the comments (when hunting the issue) probably happened due lack of data refreshing. I had to mute/unmute Image node to see render affected by changes (or under image properties press refresh icon after the path).
  • Clear Sharp Edges - is probably welcomed, but not the source of the issue
  • Why your render result black (you mentioned in comment) it is hard to say from given info.
  • moonboots's first comment gave you correct hint to solve issue and also his posted answer is a correct solution for later save at 32bit ... so all credit is going to him ... I tried to explain why (and still I can be wrong :) )
$\endgroup$
1
  • $\begingroup$ Thank you guys very much! I tried your suggestions and it worked! $\endgroup$ Jun 9, 2023 at 2:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .