1
$\begingroup$

I'm using the asset library browser for the first time, and I bought a people collection for it. I'm trying to add a group of people to the library so I can easily drag it into a scene. Here's the group: enter image description here

All the people are parented to an empty object with the origin set to it. I moved this group to a collection and marked it as an asset. However, when I drag it out of the library again, the null object is moved all the way to the side, and it dosent move or rotate the way I like. enter image description here Why is this happening?

$\endgroup$

1 Answer 1

2
$\begingroup$

All the people are parented to an empty object with the origin set to it.

Collection instancing origins are set as vector properties that hold a coordinate in scene space, not pointers to objects. If you move the objects the collection center doesn't move with it, needs to be updated manually.

enter image description here

Consequentially, the origin point of an instance is set as the Collection Offset property, which is a property of a specific collection. If you moved your group of people into a new collection then you need to set the Collection Offset for the new collection as well.

In the Properties Window check the Collection tab for properties of the currently active collection, or the Object > Collections tab to set the originins of all the collections an object may be in.

enter image description here

$\endgroup$
2
  • $\begingroup$ Thanks, this fixed it, but I'm still not sure if I fully understand. Maybe you could clarify? Why does the origin not move if the collection is re-instanced? And what exactly is the last step doing? Is it setting the origin to be relative rather than absolute? $\endgroup$
    – Pingu21
    Jun 7, 2023 at 15:31
  • $\begingroup$ Collection origin is always absolute in scene coordinates. Moving objects around has no influence on scene origin coordinates. If you moved your objects into a new collection the new collection has the default origin at [0,0,0], regardless of where your empty object is. $\endgroup$ Jun 7, 2023 at 15:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .