0
$\begingroup$

I want my model to be exported in .stl for 3d printing. When selecting all mesh and exporting as .stl it export but all mesh gets merged and 1 mesh is created. I want all my mesh to be separated after exporting. I tried to import the file and check, but it's a single mesh. How to export all the mesh separately in. stl format. Any suggestions or help? Thanks

$\endgroup$

2 Answers 2

0
$\begingroup$

Well, it is quite simple: STL does not support multiple objects in a single file. If you want to have them separately, you have to export those parts individually.

But you don't have to create multiple Blender files for this, just select one object at a time and on export enable the Include > Selection Only option.

//EDIT: I don't know when this feature was implemented, maybe it's not even new - but you can use Batch Mode > Object to create separate files per object automatically. In combination with Selection Only you could for example only export 5 selected objects in a scene with 10 objects.

stl export option

$\endgroup$
6
  • $\begingroup$ did not work same result, 1 mesh $\endgroup$
    – atek
    Jun 6, 2023 at 7:00
  • $\begingroup$ Do you have separate objects in your scene? Did you select one? This Selection Only is for selected objects in Object Mode, not parts of an object selected in Edit Mode. $\endgroup$ Jun 6, 2023 at 7:01
  • $\begingroup$ NO, I have selected all the mesh. I think i got the answer $\endgroup$
    – atek
    Jun 6, 2023 at 7:06
  • $\begingroup$ @atek Yes, I was just editing my answer to add this batch option. Don't know when this was implemented, never used it before. Still, using Selection Only should have worked with a single object. With the terminology you use it is a bit unclear what you are saying: "selected all the mesh", are you now talking about Edit Mode or Object Mode? Because the mesh is usually what you are working on in Edit Mode and only there you have a choice to select all or just parts of the mesh. In Object Mode, selecting an object always selects all its mesh. $\endgroup$ Jun 6, 2023 at 7:15
  • $\begingroup$ selected all the mesh, i mean without selecting all the mesh it will not work, if u do not select the mesh and try to export nothing will export. $\endgroup$
    – atek
    Jun 6, 2023 at 7:17
0
$\begingroup$

enter image description here

While exporting, select the Batch Mode as Object, and then export, all the objects will be saved to separate files.

$\endgroup$
1
  • $\begingroup$ You should try to use proper terminology which Blender uses, otherwise it gets a bit confusing: one object can have separate meshes. If you choose Batch Mode > Object, those meshes will not be saved separately if they belong to the same object. $\endgroup$ Jun 6, 2023 at 7:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .