I'm making a model for a Unity game. I have the model finished, as well as the Texture & Lightmap UVs on separate copies of the model from another program (Headus UVLayout). I just need to apply both UVs to one copy of the model to be imported into Unity. However, the new UV is a spaghetti mess. I've done this dozens of times before with no issues. Images below.

Final model

enter image description here enter image description here enter image description here

Both copies of the model require 2 UVs, so one can be overwritten with the other

enter image description here enter image description here

enter image description here

The final result has always been one model with two accurate UVs, one being the texture UV and the other being the lightmap UV. But now it results in a mess that doesn't even look like both UVs combined.

Am I doing something stupid? I've double checked the process and I'm not seeing anything different from how it's always been done.


2 Answers 2


When going back and forth between programs, sometimes the vertex indices get changed (reordered). Since UV maps are basically 2D coordinates stored on vertices (face corners really), mixing up vertex indices will also mess up UV maps (any attribute really).

Try using the Data Transfer operator instead, and use one of the "Nearest Corner (...)" mapping options.

Cf manual : https://docs.blender.org/manual/en/latest/scene_layout/object/editing/link_transfer/transfer_mesh_data.html

You should also look for something called "maintain vertex order/indices" in your exporter to avoid this issue next time.

  • $\begingroup$ Thanks for the help, but unfortunately Headus' export options didn't improve the situation. $\endgroup$
    – Menelin
    Jun 9 at 15:08
  • $\begingroup$ Alright, what about using Data Transfer? I saw you managed to work around the entire issue, that's good $\endgroup$
    – Hadriscus
    Jun 12 at 18:57

I haven't solved the specific problem, but I have solved the main issue. Turns out Unity can automatically make lightmaps. I'm uncertain about how efficient it is, but it works on this model well.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .