3
$\begingroup$

It does not matter what values I put into my bevel modifier, it doesn't change anything. Why is that? (picture 1)

EDIT: = picture 2

So I wanted to have a cleaner base object. However, I am having the same issue with the main shape now. I am looking at the Bevel amount and dimensions. I don't see an issue there? It is also not bevelling the edges on the backside.

Can I also have a different bevel amount on the inner circle compared to the outer edges of the shape?

I added the new file:

enter image description here

enter image description here

$\endgroup$

2 Answers 2

3
$\begingroup$

Your bevel Amount is much too high. The d-pad has a thickness in Y direction of 0.038 m, which means you cannot bevel more than 0.019 m before it overlaps. Your Amount is set to 0.4 m, that's more than 20× higher.

Since the Clamp Overlap option is enabled by default in the Bevel modifier, no changes above an amount of 0.019 m will be visible because it is clamped. Change the value to something lower and the bevel will show changes. Or disable Clamp Overlap which will of course look awful.

enter image description here

$\endgroup$
1
  • $\begingroup$ Ah that makes a lot of sense. Thank you! $\endgroup$ Jun 5, 2023 at 10:42
2
$\begingroup$

This is due to clamping, once you decrease the value below the clamping threshold, you can see the changes:

The clamping is there to ensure the created faces don't overlap, creating ugly artifacts.

Imagine that you have a thermostat and input a desired temperature using a keypad. It's reasonable for the thermostat to clamp the input to some maximum e.g. 30°C. So changing the temperature from 35°C to 40°C won't affect the temperature in the room, because after clamping, both settings get converted to the same 30°C.

$\endgroup$
1
  • $\begingroup$ Ah thank you! That makes so much more sense! $\endgroup$ Jun 5, 2023 at 10:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .