0
$\begingroup$

So i was going to make a humanoid creature for my team's game. I just wanted to show how far i came in a hour to my team, when i rendered it, background became white, my humanoid object became 2D gray. That was where everything started. First photo shows how it had to look likeHow it must look like

And second photo shows what i get when i render it What i get

That was not the end, it happens to everything, i don't know why. File: What i need What i get lol

$\endgroup$
4
  • $\begingroup$ Hello please share your file: blend-exchange.com $\endgroup$
    – moonboots
    Commented Jun 1, 2023 at 7:28
  • $\begingroup$ ... looks like shading and rendering.. share, and there will probably be a quick fix. $\endgroup$
    – Robin Betts
    Commented Jun 1, 2023 at 9:01
  • $\begingroup$ @moonboots i did $\endgroup$ Commented Jun 1, 2023 at 9:14
  • 1
    $\begingroup$ @RobinBetts i shared the file if its what you meant. $\endgroup$ Commented Jun 1, 2023 at 9:20

1 Answer 1

1
$\begingroup$

If you are in Solid Preview mode, your scene will appear grey by default, with a dark background and no material:

enter image description here

If you switch to Rendered Preview mode (the mode that will give you a preview of what your render will look like), your background will be determined by the World color and strength (for the moment it's white), the lighting will be determined by the background and the lights (you have one light, increase its strength or move it close to your object, otherwise it won't light it), and the object surface will depend on the material you've assigned to it (it's pure white as well for the moment):

enter image description here

If you want to change the world settings, you need to open the World panel, or open the Shader Editor window, switch it from Object to World, enable the Use Nodes option, change the Backgound node settings (Color, Strength, plug an HDRI if necessary):

enter image description here

$\endgroup$
4
  • $\begingroup$ While following what you wrote, i realised its happening because scene world. I'm in viewport and see the exact thing in render. How can i disable scene world? I already clicked at "Scene world" box but it only changes viewport not render, if i can't change it what else i can do? Thanks in advice. $\endgroup$ Commented Jun 1, 2023 at 9:35
  • $\begingroup$ For the render itself, disabling Scene World won't change anything, you need to open the World panel, or open the Shader Editor window, switch it from Object to World, enable the Use Nodes option, change the Backgound node settings (color, strength, plug an HDRI if necessary) $\endgroup$
    – moonboots
    Commented Jun 1, 2023 at 9:37
  • $\begingroup$ After sometime i played with options, its seems like when i make value of color darker it turns visible but if its at max or nearby it turns exactly same with background color $\endgroup$ Commented Jun 1, 2023 at 9:48
  • $\begingroup$ @Sycho_Zer0SYCH Well, yes that's what moonboots explained to you. If you have a completely white object and it is surrounded by a completely white world (meaning it's shining white light on it), what else than white on white dou you expect it to look like? I guess you should really spend some time watching tutorials on materials and the shader editor as well as lighting setups. $\endgroup$ Commented Jun 1, 2023 at 12:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .