1
$\begingroup$

I am trying to do a simple electricity plasma (lightning) simulation using displacement modifiers. It looks completely fine in the viewport but completely wrong in render.Difference between Viewport and Render

Not only that, but the light is not working as expected either.

You can see the image on the left is the render of the model with the viewport on right. It's lit correctly and the displacement modifier looks right.

  • I have checked that all the elements are set to be available for render. (eg displacement modifier is on)
  • The displace modifier is working - just not correctly. It should look like the viewport.
  • I also turned off the new feature "light tree". That also made no difference. The Render settings are the exact same as for the viewport.

I'll prepared a bug report but I am absolutely mystified.

Edit: Note the difference lighting is due to a glass face I had hidden. The main thrust of the post remains an issue though.

$\endgroup$
2
  • 2
    $\begingroup$ hello could you please share your file (with just the lightning object)? $\endgroup$
    – moonboots
    May 30, 2023 at 16:25
  • $\begingroup$ Hi yes. Note the edit in the main body: dropbox.com/s/wcz9s0d3cbuwm8c/Test%20Lightening.zip?dl=0 Also note I tested this in 2.83 and the problem occurs in Cycles but not in Eevee. Eevee looks correct. In 3.4.1, the problem is in both Eevee and Cycles. $\endgroup$ May 30, 2023 at 17:07

1 Answer 1

1
$\begingroup$

You've activated the Motion Blur option, it leaves a traces that makes the lightning render look different from the preview, so either change the motion blur settings or disable it?

$\endgroup$
3
  • $\begingroup$ I reported this as a bug and got a similar response. That does indeed seem to be the issue. The reason I missed it is because the animation shows the arc as much much thicker. I was rendering a single frame to check. It's possible to turn off motion blur for just that object (something I didn't know before). $\endgroup$ May 31, 2023 at 10:15
  • 1
    $\begingroup$ Only report a bug if you're about sure that it's a bug, or at least wait for the answer in Blender Stack Exchange ;) $\endgroup$
    – moonboots
    May 31, 2023 at 11:06
  • $\begingroup$ I was pretty sure it was a bug, but you are right I should have waited here. The relevant information is here: docs.blender.org/manual/en/latest/render/cycles/object_settings/… I think this relevant to my situation: "Warning An object modifier setup that changes mesh topology over time can not render deformation motion blur correctly. Deformation blur should be disabled for such objects. Common examples of this are animated Booleans, Deformation before Edge Split, Remesh, Skin or Decimate modifiers." $\endgroup$ May 31, 2023 at 11:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .