I'm having some really odd issues getting a render to output to files correctly. I have a really simple blend. A single object with a fire sim. There are just 9 frames and I'm rendering out the last frame. I only want a single object and the fire sim in the final render with a transparent background for inclusion in another animation.

There is only one View Layer and a really simple compositing node setup.

enter image description here

Hitting F12 and getting a render in the Image Editor is perfect. The issue is getting that into files on disk.

When looking at the image in the Image Editor after rendering the frame I've tried saving the image to an exr and png, the fire and composite results are missing. The only thing that is put in the file is the input to the composite nodes which excludes the fire sim.

Switching to view the Viewer node output in the Image Editor also shows the complete render I want to save but saving that, same deal. No fire, no composite results. It just saves the vanilla rendered object.

So I tried rendering out as an animation of openEXR files. That also has the same issues. It doesn't include the fire sim or the composite results.

I don't even know what to google at this stage as all the solutions and techniques are the things I've tried already.

I've checked all the obvious things like materials, render visibility etc. If any of those things were an issue I wouldn't see them in the Render Results. The render I do see is precisely what I want I just can't seem to persist it on disk.


I've just turned off the Transparent Film option and re-rendered and saved that render and it's included the fire and compositing but with a black background.

I was under the impression that option was designed for what I'm trying to do?

How can I get this setup to just render out the object I want with a transparant background if the Transparant Film option breaks my file saves? Or is this a bug? I don't understand why the Transparent Film would work to produce the render I need but that saved file is missing parts.


1 Answer 1


So I've managed to get this working with the following node setup. Transparent Film is still enabled. The trick is to massage the alpha channel data. Something to do with the wrong kind of alpha data which I don't fully understand yet.

enter image description here

The main nodes to look at are the Render Layers -> Add -> Colour Ramp -> Set Alpha.

Set Alpha is set to Replace Alpha

In my situation the colour Ramp allowed me to claw back some colour in the fire, the Blur is there to feather the edge of the alpha channel data.

Saving the output to openEXR/PNG should now work for you.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .