1
$\begingroup$

This has probably been answered multiple times, but I can't find a solution. I'm building a scene to model stage lighting. I have a bunch of lights and I want an easy way to control their colors and powers. To do this, I created a cube and assigned a material to it which has a bunch of RGB inputs and values like this: enter image description here I then used "Copy as new driver" on each of Red, Green and Blue, then pasted these drivers onto the Red, Green and Blue of the spotlight object in my scene. I did the same for the Power value. This works... once. And it works when I go into the driver editor and click "Update Dependencies". However, when I interact with the RGB picker or the Power value in the cube's material, the light's color doesn't update dynamically, and I would really like it to!

And yes, I have "Auto run Python scripts" enabled: enter image description here

Does this need Python code? Or am I missing something?

By the way, the RGB and (power/10.0) values of the spotlight are used for the emissive material of some filled circles to show what the lights look like. This is also done through the same type of drivers, and it updates dynamically with no problems. is it possible that it's not dynamically updating because the lights' RGB properties are themselves data sources for drivers? enter image description here

Thanks!

$\endgroup$
1
  • $\begingroup$ i would recommend providing a blend file so we don't have to rebuild your problem to prove/find a solution $\endgroup$
    – Chris
    May 18, 2023 at 7:33

1 Answer 1

1
$\begingroup$

"Auto run python scripts" shouldn't be required based on your description.

I tested it (also in B.3.4.1) and indeed I could reproduce the problem:

The workaround I found is to also have a driver in the RGB node, for example use #1 driver as Alpha:

$\endgroup$
2
  • $\begingroup$ Wow. Thanks! I'll try it tonight when I get home. $\endgroup$ May 18, 2023 at 17:03
  • 1
    $\begingroup$ Thanks, Markus - that worked! All I did was "add driver" on the colored bar on the RGB node in the material. I didn't even edit anything in the driver, and I didn't assign it to control anything. And now it works! One of the mysterious behaviours of Blender... $\endgroup$ May 18, 2023 at 22:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .