3
$\begingroup$

I'm trying to apply the modifier to the closet and the window you see in the screenshot (I'm actually following a tutorial so he might have different settings, but I didn't manage to solve my issue). The modifier works just fine on the bed frame though.

What is also strange is that if I try to change any settings, or even apply them without copying from the bed frame, they don't get applied to the window or the closet. The Auto Smooth is set to $180°$, and if I try to change it I see the difference only if I go below a specific range, like it's the same between $90°$ and $°180$, and only below $90°$ it changes.

I already tried applying the scale, and re-make them again, but nothing worked. At this point, I have no idea about what I should do.

screenshot of blender interface

This is how it should look:

enter image description here

$\endgroup$
16
  • 1
    $\begingroup$ Of course the Auto Smooth doesn't show any changes between 90° and 180°. The value means, every angle below this gets shaded smooth. Since you seem to have mostly 90° angles on your objects, there is nothing above 90° which is not smoothed. Setting Auto Smooth to 180° is like disabling it completely. $\endgroup$ May 15, 2023 at 8:17
  • $\begingroup$ @GordonBrinkmann the thing is that I also tried to follow what the guy in the tutorial had, and he applied 180° to all of the above-mentioned objects. And with 90° they don't change much in terms of being close at least to the result I'm trying to achieve. Thank you for the hint tho! $\endgroup$ May 15, 2023 at 8:20
  • $\begingroup$ The Auto Smooth option is used to have smooth objects not overly smoothed so that certain angles still look sharp. It only really makes sense to use it with values below 90°, that's why the default value is 30°. What tutorial is that, because setting it to 180° makes absolutely no sense - but I wouldn't say that every tutor always knows what he's doing... $\endgroup$ May 15, 2023 at 8:23
  • 1
    $\begingroup$ @AlexKrugeri I guess you have messed up your mesh somehow. Go to Object Data Properties and under Geometry Data check if there is a button Clear Custom Split Normals Data. If so, click on it so that it resets to Add Custom Split Normals Data. The reason why he sets Auto Smooth to 180° is that he does not actually want the Auto Smooth to take care of sharpening the edges, but he enables the Harden Normals option in the Bevel modifier, and this needs Auto Smooth to be enabled in order to work. But without the modifier this setting would be useless. $\endgroup$ May 15, 2023 at 8:39
  • 1
    $\begingroup$ He probably has enabled the Shading > Harden Normals option of the Bevel modifier, which needs the Auto Smooth enabled and will smooth the bevels but not the faces, have you enabled this option? Edit: Oops but yours seems to be enabled $\endgroup$
    – moonboots
    May 15, 2023 at 8:44

2 Answers 2

5
$\begingroup$

As Gordon says, you need to reset the normals, in the Object Data panel > Geometry Data, click on Clear Custom Split Normals Data. Also you have overlapping vertices, which prevents the bevel (because it will make some faces intersect), you need to select all and press M > Merge by Distance.

$\endgroup$
3
  • $\begingroup$ Thank you so much for adding your solution as a formal answer! I really appreciate your help in resolving my issue. Your solution worked perfectly and solved the problem. I've upvoted your answer and marked the question as answered. Thanks! $\endgroup$ May 15, 2023 at 9:08
  • $\begingroup$ You're wekcome ;) $\endgroup$
    – moonboots
    May 15, 2023 at 9:16
  • $\begingroup$ I'm so stupid... just reading your first sentence (which was just a guess on my behalf and not the problem in this case) and then writing my own answer about merging :D $\endgroup$ May 15, 2023 at 9:22
4
$\begingroup$

I cannot recap what exactly you did with your mesh. But the only thing I saw immediately is that the Auto Merge option at the top of the viewport is not enabled - which he uses in the tutorial and explains that this might help merging vertices that are accidentally duplicated.

So I ignored the strange shading and when I looked at your mesh I saw that despite the fact you have set the bevel Amount to 0.04 m, there is absolutely no bevel visible on the edges - which means the Clamp Overlap option is limiting the bevel because there are vertices too close together, like: in the same location.

Pressing A in Edit Mode on the cupboard to select all and then M > Merge > By Distance resulted in the message: "Removed 40 vertice(s)". After that, the edges were beveled and the shading looked normal. On the window there were 24 vertices removed.

I can only recommend to every beginner to thoroughly and carefully follow a tutorial to make sure you are doing everything like it is shown there to eliminate possible errors.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .