3
$\begingroup$

There are websites full of procedural textures and shaders which you can download, but using Append to bring in the files does not bring in a working material. Even though all the files appear in the materials and texture lists, all I get is a flat colour in the material preview.

In other words the setup with the nodes, which forms the procedural texture does not come in with the texture or materials files via Append or link.

If anyone does know how to import an entire material and not just it's component I would be eternally grateful!

$\endgroup$
  • $\begingroup$ The textures might be being treated as images . . . Does it work on a UV unwrapped mesh? $\endgroup$ – VRM May 2 '15 at 11:37
  • $\begingroup$ I'm assuming you're using Cycles, did you check "Use Nodes"? What are you clicking on in the append menu? I sometimes have to group the entire node setup and then import the group and connect it up. $\endgroup$ – meed96 May 2 '15 at 16:51
  • $\begingroup$ Do you have OSL enabled in the render tab? It would be helpful if you posted a link to one of the materials and preferably from a site that does not require a login/password. One thing to note here, procedural textures tend to come in the form of code, the formula is either written into the main source code or it must be added in to the material using a script node using OSL. For imported code, it's unlikely there will be a material preview if that's what you are expecting to see. $\endgroup$ – MarcClintDion May 5 '15 at 8:46
  • $\begingroup$ Thanks for your helpful replies. It seems that when importing some procedural materials the nodes come in automatically with everything connected and working (materials I've paid for). With some others more setup is needed (generally speaking the free ones). Some I am unable to get to work at all. Others "just work". As I am new to Blender, I think the easiest thing for me in these early stages is to stick with materials I've bought as they seem to just work. When I know more I can return to the free ones and see if I can get them to work as well. Thanks again for your help. $\endgroup$ – Antiphones May 18 '15 at 8:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.