0
$\begingroup$

I’m trying to add a fixed color (say white) in the background… however it is surprisingly challenging. I tried to enable transparent film mode and then use the compositor like:

enter image description here

You can see that the white is actually more like a "grey".

(I made sure to disable filmic look, as I understand that blender can’t deal with different color space in the compositor, but still no luck)

Any solution? I don’t want to use another tool like ffmpeg on transparent pictures as I want to export to jpg that takes significantly less space than png/exr.

$\endgroup$
4
  • $\begingroup$ Check the alpha channel of your render. This usually works without any issues. $\endgroup$ May 4, 2023 at 14:35
  • $\begingroup$ @MartynasŽiemys Well the alpha contains only 0 values (according to Krita), like all channels, and in krita adding a white background gives me a perfect white as expected. $\endgroup$
    – tobiasBora
    May 4, 2023 at 16:58
  • $\begingroup$ Could you share the file? unable to reproduce that on my side. Please use blend-exchange.com $\endgroup$
    – lemon
    May 4, 2023 at 16:59
  • 1
    $\begingroup$ @lemon problem solved, I was not changing the CM in the right tab! $\endgroup$
    – tobiasBora
    May 4, 2023 at 17:25

1 Answer 1

1
$\begingroup$

Oh, Forester (thanks!) made me realize that the color management should be changed in another tab, the one I changed should be left with the default setting:

https://media.discordapp.net/attachments/285639647567282179/1103732590336278698/image.png?width=234&height=556

Another trick to mix filmic and non-filmic (thanks again!) is to stay in filmic but manually add a value of around 10 instead of the maximum 1 (the higher the closer to actual white it will be, but you will get ugly aliasing with too high values)

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .