1
$\begingroup$

I am trying to create CSGO models and am encountering an issue. The model is only being lit from one side, which I presume is the environment lighting.

I have added numerous different types of lights to the scene to evenly light both sides to no avail. Am I missing a setting? What am I doing wrong?

For example: this first image the right side is darker as opposed to enter image description here

The left side where it is being lit up, closer to what I expect. enter image description here

This results in the UV applying lighting to only one side as well, making it look improperly shaded in game. enter image description here

$\endgroup$
2
  • $\begingroup$ Are you in Material preview? In that case the lights won't be taken into account. If you are in Rendered preview you need to make sure that the Scene Lights option is activated in the Viewport Shading. $\endgroup$
    – moonboots
    May 2, 2023 at 6:16
  • $\begingroup$ @moonboots This was it. I didn't realize there were options for that. Turning on "Scene Lights" allows me to properly light my model. Thank you. $\endgroup$
    – phaynes
    May 2, 2023 at 22:44

2 Answers 2

0
$\begingroup$

In shader editor, if you switch node editor from object to world, you can decrease the power of environment lighting that is affecting your model. You can test different environment/light point values to get what you need.

$\endgroup$
0
$\begingroup$

If you are in Rendered preview you need to make sure that the Scene Lights option is activated in the Viewport Shading

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .