I'm trying to cut a face along vertices. Basically, I've got one object (all one mesh) and I need to cut some parts out. I've already got the vertices in the right places. I've managed to create a face on the entire top surface, but I now need to cut out the shapes outlined by the vertices.

I tried the knife tool, but it doesn't seem to snap to the vertices, even when I turn on the magnet icon. I also tried selecting the loop edges for all faces involved and using the intersect (knife) tool in the faces menu. But that resulted in some very strange geometry.

Any ideas how to get the knife tool to snap to vertices?

cut along vertices

  • 1
    $\begingroup$ Use the Knife Project tool? $\endgroup$
    – moonboots
    May 1, 2023 at 19:47
  • $\begingroup$ If you share your file with blend-exchange.com if will be easier to help you $\endgroup$ May 1, 2023 at 19:47
  • $\begingroup$ for me - it looks like your vertices are not part of the mesh-face - because they couldn't be a filled face like you show here. $\endgroup$
    – Chris
    May 2, 2023 at 5:10

2 Answers 2


I just tried it out, and as i wrote in the comment, this behavior where the knife doesn't snap only appears, if your vertices are not part of the face:


enter image description here

The yellow vertices are not part of the face (you can recognize this because Blender cannot have holes in a face without edges which are connecting to the "outside" of the hole. They are just "added vertices" to the mesh.

So if you want to make a cut, you can use "knife project" for that, as moonboots proposed in the comments:

  1. select all vertices which you want to make a hole of

enter image description here

  1. press P -> selection

  2. select your "face" object and TAB -> edit mode

enter image description here

  1. select your "hole" object in the outliner with "shift" select

enter image description here

  1. press numpad 7 to go to top view

  2. F3 -> knife project

enter image description here


enter image description here

now you can select the face and delete it:

enter image description here


Since you already created all the necessary vertices for the holes you can do the following, if the face you want to cut is flat and all the vertices for the holes lie in the same plane as the main face:

  1. Holes in faces need supporting edges. Press K and use the Knife tool to make two cuts from one border of the face to the opposite side so that they cross through the "soon-to-become-holes".

    cut edges with knife tool

  2. The Knife doesn't need to cut the hole shapes - you only need the edges across. Now select all vertices with A. Enable the Auto Merge function at the top right of the 3D Viewport and make sure that under Options > Split Edges & Faces is enabled.

    select all and enable auto merge

  3. Next you press G followed by 0 (zero) so that the Move tool is theoretically moving the vertices, but they stay in place (do not abort the movement with right-click or Esc). Confirm the movement with Return or left-click.

  4. After this operation, the vertices are cut into the face. You can now select the inner faces and delete them with X > Delete > Faces to get the holes.

    holes cut into face

Just a quick note: if the "hole vertices" are just edges, the faces can simply be selected and deleted because the underlying face got split up into these faces. If the "hole vertices" are shapes filled with faces themselves, you'll get double faces where the holes: the original faces of the hole shapes and the cut faces of the underlying plane, so you have to delete them both to get a hole.

And one more thing: If you let the Auto Merge function enabled after this, it might happen you accidentally merge and split vertices and faces just by moving, rotating or scaling something which can mess up your mesh. So I would recommend to disable this function after creating the holes.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .