34
$\begingroup$

Is is possible to remove the curves and only have the mesh of a tree that was created with the saplings add-on?

I'd like to apply a decimate modifier to have a few low-poly trees, but this doesn't work because of the curves. I get this message: "Cannot apply constructive modifiers on a curve."

$\endgroup$
41
$\begingroup$

The reason you can't use a "constructive modifier" on a curve is because a curve has to be defined by mathematical control points instead of free-floating vertices. You can visualize the decimate modifier in the viewport or render, but if you were to actually apply it you might create a shape that can't be represented by the control point equations, and then you would have broken mathematics.

The way to fix this is to convert your curve to a mesh. Select the tree and use AltC:

Convert menu option

Here's the result:

Result of conversion

Then any mesh-based modifiers will work fine.

$\endgroup$
  • 1
    $\begingroup$ Object Mode! then Alt+C. It does something unrelated in Edit Mode. $\endgroup$ – David Lotts Nov 11 '17 at 6:42
  • $\begingroup$ Is Alt-C version specific? It doesn't work in 2.80 $\endgroup$ – Jay Feb 27 at 20:34
5
$\begingroup$

Just as a note, if your goal is just to reduce the number of polygons, you don't have to convert to mesh. Select the curve and switch to curve data on the properties viewer. By changing the preview or render resolution of the curve, you reduce the number of vertices generated per control point. By changing the bevel resolution, you change the number of vertices used to define the thickness of the curve. By reducing these values, you can create a curve object with a very manageable number of polygons. (But there may be other modifiers you'd like to use, in which case conversion to mesh is appropriate.)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.