1
$\begingroup$

So I have a nice dragon that I've been working on for quite some time. Recently I decided to add scales by the Shaders with a simple Texture image, which is connected to the Bump node (oh, and there is also a Texture Coordinate whose Generated is connected to the Vector of the texture). The thing is that the texture always looks stretched on one of the axes, like this: How it looks on the Y axis: enter image description here How it looks on the X axis (I want it to look like this on the Y as well): enter image description here The texture I'm using:

enter image description here I don't want to use any UV here, is there a way to fix it? please help me.

$\endgroup$
2
  • $\begingroup$ Show an image of your shader nodes and we might be able to help. I assume you've applied the scale to your object? $\endgroup$
    – John Eason
    Commented Apr 23, 2023 at 8:23
  • $\begingroup$ By default the projection will be flat. You could switch the Image Texture from Flat to Box, and play with the Blend option to see if you can make the seams unnoticeable, but it may not work well. The other solution is to unwrap your mesh (Smart UV Project) and paint the texture on it with the Draw brush in Stencil mode $\endgroup$
    – moonboots
    Commented Apr 23, 2023 at 8:45

0

You must log in to answer this question.

Browse other questions tagged .