2
$\begingroup$

I have this beveled rectangular prism here and I want it to be shaded smooth so that the bezels are smooth. But it causes the long flat faces to look weird, like they aren't flat. How can I make just the edges to the flat face smooth, and not have the entire face be smooth?

enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ In what way do the faces "look weird"? Have you checked Auto Smooth on the Normals tab or used the Shade Auto Smooth option if you're using a recent Blender version? $\endgroup$
    – John Eason
    Commented Apr 17, 2023 at 17:32

1 Answer 1

4
$\begingroup$

Use the Weighted Normal modifier, it will limit the smooth shading to the small faces and won't try to smooth the large ones. Note that you need to enable the Auto Smooth option to make it work:

enter image description here

$\endgroup$
1
  • $\begingroup$ Exactly what I needed, @moonboots! $\endgroup$
    – sdasda
    Commented Apr 17, 2023 at 22:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .