When using volume scatter on a massive cube, with an hdr image for lighting, I’m getting wildly different renders between what I see in my viewport vs what I get in my final render. this is the final render

this is the viewport

I thought at first I had something turned off in the viewport that was visible in the render but that’s not the case. I almost think it’s something to do with the hdr image and how the volume scatter renders in front of it? I can even turn up the density of the volume scatter until the viewport is nearly black, and the render will be just a slight bit darker.

I much prefer the viewport results and I can’t figure this out.


  • $\begingroup$ Hello could you please keep only several objects of your scene (enough to see the problem) and share the file? $\endgroup$
    – moonboots
    Apr 17 at 13:23
  • $\begingroup$ I have added the blend file, hopefully this can help determine the issue $\endgroup$
    – user53924
    Apr 19 at 3:03
  • $\begingroup$ In the file you share the volumetric cube is disabled for render, if I enable it I can't see any difference between preview and render, Also I can't see any image texture in your materials, I'm not sure it would make a difference, but I don't see the same thing as what you show $\endgroup$
    – moonboots
    Apr 19 at 7:52

1 Answer 1


It might have something to do with your render settings varying from your viewport settings. Could also be the number of light paths you have set for volumetric. I believe there is a weird bug with the volume being plugged into the world shader when using an hdri but if you are just using a cube then it should be fine.

  • $\begingroup$ To add to that answer from Isaac , there's a forthcoming fix mentioned in today's Blender Today Live video at this timestamp which might be relevant here. $\endgroup$
    – John Eason
    Apr 17 at 18:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .