I am returning to Blender after more than a year away and I have discovered that I do not know what the (presumably new) workflow is for adding noise modifiers to various values.

In this case, I have a pretty basic emission shader: My emission shader

Note the presence of a keyframe for the emission value. Over here in my graph editor, I discovered that I can't actually add a noise modifier via the N-Panel. My Graph editor

And it's not just this project. I added a point light in an attempt to add some flickering to that and I had the same issue.

My presumption is that there is something different in the workflow, but I can't be certain. If anyone can help, I would appreciate it.


Note: This is a repost of a woefully inadequate original post created with too much haste.

Follow-up: I'm providing this additional screenshot to illustrate that all needed elements are selected, yet the N Panel gives me no options for affecting those values. Follow-up illustration


1 Answer 1


Keep the node selected, open the Graph Editor, on the left select the good track (Shader Nodetree > Default Value (Value)), open the N panel, click on the Modifiers tab, click on Add Modifier, add the Noise modifier, tweak the parameters:

enter image description here

  • $\begingroup$ This does not work. The drop-down where I would select "Add modifier" is not present (please see screenshot #2). Can you confirm that you have done the above in 3.5? Because that's the environment I'm in and I'm still dumbfounded by this Thing that was dirt simple to do before today... $\endgroup$ Commented Apr 16, 2023 at 13:48
  • 1
    $\begingroup$ You need to open the Graph Editor $\endgroup$
    – moonboots
    Commented Apr 16, 2023 at 13:53
  • $\begingroup$ Oh DERP DERP. THANK YOU. You are like a beacon of safety. Still years on and you are fixing user error... $\endgroup$ Commented Apr 16, 2023 at 13:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .