2
$\begingroup$

enter image description hereenter image description here

enter image description here

enter image description here

When i add a texture image to the background of the world, an unwanted purple color comes with. I don't know how to delete it (the purple color). I see it in the preview before adding the texture image from my folder. After adding the image, the preview is OK but if i render my 3d view i have always this purple color with my image. Somebody has a solution ?

(with blender 2.74)

Thanks for your help.

Matthieu

P.S : My light is not purple and it is not a duplicate. No files are missing and i don't use blender render but cycles render. I can see my image in the preview window. My problem is : when i assigne a texture the background is a mix with purple color and my texture. I don't want this purple color !

I think it's a bug. It works great with my older version of blender (2.66a).

$\endgroup$
  • $\begingroup$ Sorry but it is not my issue, I use cycles render $\endgroup$ – Matthieu Apr 27 '15 at 21:32
  • $\begingroup$ @Matthieu can you add some screenshots to demonstrate the problem ? $\endgroup$ – Chebhou Apr 27 '15 at 21:33
  • $\begingroup$ Yes, If somebody can explain me how to add some screenshots $\endgroup$ – Matthieu Apr 27 '15 at 21:36
  • 3
    $\begingroup$ In blender when you are missing a texture you get pink. Looking at your screenshots it seems like you have no image texture assigned, therefore you get the pink color. That goes both for cycles and internal. $\endgroup$ – user1853 Apr 27 '15 at 22:14
  • 4
    $\begingroup$ do you have other objects in the scene , and please upload the blend file $\endgroup$ – Chebhou Apr 27 '15 at 23:13
2
$\begingroup$

The rest of the environment outside of the window probably doesn’t have a texture on it since you’re trying to use window space for the mapping. The purple is probably being emitted from the environment dome that’s outside your camera view

$\endgroup$
0
$\begingroup$

There are some textures that have to be set to non-color data, for example this ones used for bumb mapping or alpha masking. Otherwise you have purple lights or another issues when baking textures.

$\endgroup$
  • $\begingroup$ Can you elaborate on this? Particulary to show how setting any image to Color instead of Non-Color Data can cause purple color in the environment? $\endgroup$ – Mr Zak Nov 1 '17 at 11:36
0
$\begingroup$

The Background Shader does need an Envoirment Texture and not an Image Texture

purple always means missing texture, this time because the type is wrong.

the alternative would be to put it back to color.

And maybe set the vector back to default.

enter image description here

$\endgroup$
0
$\begingroup$

Go to the World tab then go down to the Surface>Background tab, click it and in the top right corner there are Remove and Disconnect buttons.

Click Remove and your background should return to black, white or grey.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.