2
$\begingroup$

I had this working then...

I had this working with Blender 3.4.1 which I downloaded from blender.org, extracted, moved to /usr/local/ set the permissions to root, installed the master version of the Sverchok addon and pointed the python path to the directory listed in the freecad python console which on this occasion turned out to be /tmp/.mount_FreeCANxa7Pa/usr/lib/

The Freecad version is FreeCAD_0.20.2-2022-12-27-conda-Linux-x86_64-py310.AppImage

That was a month or so ago. I'm running linux mint 21.1. I've run a couple of system updates in between then and now but, when I came back to it I found that, despite providing the updated python path and restarting Blender it just crashes, Blender I mean.

I went through removing the /usr/local/blender-3.5.0-linux-x64/3.5/python/lib/python3.10/site-packages/freecad_path.pth file which got blender running again but still not allowing freecad to be recognised.

So I attempted to completely remove Blender (sudo apt-get remove --autoremove blender) and installed version 3.5 which still uses Python 3.10

Blender still crashes in the same way. It'll run, Freecad will run but adding the path to Freecad python in Sverchok prevents blender from restarting.

Has anyone got a recent set of apps configured with Sverchok and with the ability to interact with Freecad?

Or any suggestions how to troubleshoot this. I'm a Linux newbie and I'm concerned that I might be running around in circles because I'm not doiung somewthing properly with permissions or something :-(

$\endgroup$

1 Answer 1

2
$\begingroup$

I got it working again :-)

Here is my set up I'm using Linux Mint: Mate version. It is as 21.1

Using the Mint software manager I installed the system (not the flatpak) version of FreeCAD. The software manager reports the version as 19.2+dfsg1-3ubuntu1

I downloaded Blender 3.4.1 from the blender website and placed it in my home directory where I extracted the downloaded file. I ran the blender executable and opened preferences I downloaded and installed the Sverchok addon. It was called Sverchok-master and reports as being version 1.2 In the Dependencies section, under Extra Nodes I set the FreeCAD path to /usr/lib/freecad-python3/lib/ (As indicated here [url]https://github.com/nortikin/sverchok/wiki/FreeCAD[/url]) This time I got a tick

I hope this will save other's from the hours of research that I undertook to get a working solution

$\endgroup$
1
  • $\begingroup$ main thing here - python version of Freecad and Blender have to be the same $\endgroup$
    – nikitron
    Apr 24, 2023 at 16:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .