1
$\begingroup$

I was expecting the Curve Modifier to deform a mesh based on the curve's shape. So when I use a curve with a circular shape, I would expect the mesh (a hexagon mesh with an Array modifier and Subdivision modifier) to deform or wrap around along the circular path without any weird unexpected center stretching. Here on the left image, I'm using a Bézier Circle curve. On the right I'm using a simple Circle (using the NURBS circle curve has the same effect). Why does the Curve Modifier with Bézier Circle as Object handle this deformation differently and what is the logic behind this? I'm using X as Deform Axis in both scenarios and all objects are on the XY plane. When you convert the shape to mesh and then back to a curve then it works like on the right image. I tried adjusting both curves' Object Data Properties but nothing changes this behavior.

enter image description here

$\endgroup$
3
  • $\begingroup$ Just a guess. Have you scaled your deforming curve in Object Mode, and then applied the scale? That bakes the scaled radius into the control-points, normally desirable for preserving the appearance of a profile, but scaling deformed 2D instances non-uniformly. TLDR; Check the radius. $\endgroup$
    – Robin Betts
    Apr 7, 2023 at 17:06
  • $\begingroup$ @RobinBetts ah interesting. I did apply the scale so it should have worked. When I uncheck Radius in the Curve Deform of the Object Data Properties it works. What gives? Why does the radius not change even after applying the scale? $\endgroup$ Apr 8, 2023 at 0:55
  • $\begingroup$ It also works if I don't apply the scale and leave Radius checked. So I'm not allowed to apply the scale but I'm used to apply the scale of any object I resize in Object mode. $\endgroup$ Apr 8, 2023 at 0:57

1 Answer 1

1
$\begingroup$

I'm used to Apply the scale after scaling an object in Object mode. I didn't realize you cannot apply the scale when you use a curve as deformation in the Curve modifier. In the case when you have already applied the scale which I think is irreversible, unchecking Radius option in Curve Deform fixes the issue. That's the case for every curve object. Always better to resize in Edit Mode.

enter image description here

$\endgroup$
3
  • $\begingroup$ Applying the scale may be irreversible, but you can set the Radius back to 1 in the curve's N panel in Edit Mode 3D View. You may need to reset other Object Mode transforms.. by the look of your reference, Location, relative to the array. The rule: 'Never scale in Object Mode during modelling' (at least, without a slight shudder) holds up, IMO :) $\endgroup$
    – Robin Betts
    Apr 8, 2023 at 8:05
  • $\begingroup$ @RobinBetts thanks! out of curiousity i tried scaling it back to dimension 2m (1m radius) and then applied but it would look different. not like the original 1m radius it was. but yeah i will keep that in mind not to scale curves in object mode. $\endgroup$ Apr 8, 2023 at 11:43
  • 1
    $\begingroup$ I never scale anything in Object Mode during modelling.. except if dimensioning, and then I apply straight away. We could chuck out half the questions on BSE if everybody did that. :) $\endgroup$
    – Robin Betts
    Apr 8, 2023 at 17:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .