0
$\begingroup$

In previous versions of Blender, I was able to click on the different points of a 3D gizmo to manipulate it.

However, after the 3.4 update this no longer works. It just draws a select box. I wondered if it was just a bug for me for that engine, but having installed 3.5 I see it's the same.

https://youtu.be/r9QZdI0dnqk <-- now working!

I can't figure out what's wrong. I've tried resetting the keymap and it doesn't fix it.

enter image description here

I've tried the different Drag modes: select box, active tool, tweak. It's the same in Object and Edit mode.


Edit: https://youtu.be/fdU6jfdY2OU

Restoring factory setting fixes it, but the issue resets when Blender is opened again.

I suspected it'd messed something up with my custom keymap, but even with the default keymap it doesn't work. The above video is using only Blender's default keymap. What is going on?


SOLVED:

I went into the AppData 'config' folder for 3.5 and copy-pasted everything from 3.3 into it. Apparently reloading factory settings and changing the keybinds wasn't successfully saving to the config or something.

$\endgroup$
8
  • $\begingroup$ It's the gizmo on the cube that you're trying to move? Drawing the select box just means that you're in Box select mode which I think is the default. You should be able to simply drag any of the 3 arrows or the white circle to move the cube around. What icon is selected if you press 'T' to bring up the toolbar? - Should be the Move icon (4 arrows). Can you move the cube with the 'G' key as usual? $\endgroup$
    – John Eason
    Commented Mar 30, 2023 at 14:19
  • $\begingroup$ Hi, I've changed the YouTube video to one that works, you can see the exact nature of the problem. I've tried select box, active tool and tweak and it's the same. The hotkeys work as normal. I'm experienced in Blender but havn't had this issue before and can't find a setting to fix it. @JohnEason $\endgroup$
    – Candle
    Commented Mar 30, 2023 at 14:52
  • 1
    $\begingroup$ No idea I'm afraid. It works the same in all 4 versions that I have installed here. Unless anyone else here has an answer I'd try using File > Defaults > Load Factory Settings but you'll lose any other settings that you have set up of course. $\endgroup$
    – John Eason
    Commented Mar 30, 2023 at 17:09
  • $\begingroup$ I followed your advice and reloaded factory settings; then just put back all my other settings. It works now, guess it's just a ghost in the machine. $\endgroup$
    – Candle
    Commented Mar 30, 2023 at 18:04
  • 1
    $\begingroup$ Cosmic rays! :^) You'll have to do the same with the other version if you still want to use both 3.4.1 and 3.5. $\endgroup$
    – John Eason
    Commented Mar 30, 2023 at 18:06

1 Answer 1

0
$\begingroup$

While I don't know what triggers this (perhaps an accidental use of the 'W' key keyboard shortcut), the fix is very easy:

With the Move tool selected, look in the upper-left corner of the viewport, and where it says Drag: make sure the dropdown is set to Active Tool (e.g. the Move tool you selected), rather than Select Box or anything else.

Sometimes it seems the proper Drag mode is stuck, so you may need to toggle a few different modes before it starts working again.

enter image description here

$\endgroup$
2
  • $\begingroup$ That setting mirrors the action which is set by toggling with the W key. For instance set the action to lasso and when you select the Move icon again you'll see that the Active Tool dropdown has also been set to Lasso. $\endgroup$
    – John Eason
    Commented Jun 28 at 22:18
  • $\begingroup$ Thanks, that's probably what I hit. $\endgroup$
    – Jamin Grey
    Commented Jun 28 at 23:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .