4
$\begingroup$

This may be a dumb question, but did Loop Cut and Slide get removed with Blender 2.74? I have 2.73 and 2.74 both on my computer, and it works fine on the old one, but when I go to User Preferences and try to change the key it's mapped to in the new one, it's just not listed at all. I tried resetting to factory defaults and uninstalling/reinstalling, but the option still isn't there.

Edit: I should mention my OS is Windows 7 64-bit with the installed version of Blender, not the portable exe. When I try to use Ctrl + R on a mesh, nothing happens. I've attached a screenshot of what happens when I go to Input prefs and search for actions using the shortcut "Ctrl R" in 2.74

Screeenshot of Blender 2.73 showing the option to map "Loop Cut and Slide" to a key

Screeenshot of Blender 2.74 showing no option for "Loop Cut and Slide" enter image description here

$\endgroup$
  • 1
    $\begingroup$ No, it most certainly did not get removed. In edit mode what happens when you press Ctrl R? $\endgroup$ – David Apr 24 '15 at 17:58
  • $\begingroup$ You have to change to Key Binding $\endgroup$ – VRM Apr 24 '15 at 18:08
  • $\begingroup$ @NoviceInDisguise is this a bug ? $\endgroup$ – Chebhou Apr 24 '15 at 18:11
  • $\begingroup$ @Chebhou I don't think so, need more info from the OP to be sure though. Could be. $\endgroup$ – VRM Apr 24 '15 at 18:11
  • 1
    $\begingroup$ @APant can you run this in the console to see what it outputs bpy.ops.mesh.loopcut_slide $\endgroup$ – Chebhou Apr 24 '15 at 18:44
5
$\begingroup$

It looks like you are using a custom keyboard shortcut preset. The default is called "Blender":

enter image description here

If you reset to factory settings in File > Load Factory Settings does it appear? This won't be permanent unless you save your startup .blend, so you can check to see if it's there without deleting your customized setup.

Also check to see if the operator is there by pressing Space in the 3D view while in edit mode and typing in "loop":

enter image description here

$\endgroup$
2
$\begingroup$

In the Input tab, change the search type to Key-Binding and type Ctrl R. You should now see a result similar to this:

Example

The command you are looking for is the second from the top.

I got this result with Blender 2.74 on Windows. Note that if this doesn't bring it up, you must have done something specific to disable it. Either that or it is not supported for your specific OS.

$\endgroup$
  • $\begingroup$ Weird as it is, it's not there. I noticed this as soon as I first tried 2.74, older versions have always and still do work fine. I don't know how I could have disabled it, but I suppose it's possible, though I would think it wouldn't survive a reset to factory settings. I edited toe original post to include my OS and a screenshot of what happens when I search for Ctrl R, just like your screenshot. $\endgroup$ – APant1 Apr 24 '15 at 18:30
  • $\begingroup$ @APant1 I am using the default build, and it shows up and is enabled by default. What OS are you running? $\endgroup$ – VRM Apr 24 '15 at 18:31
  • $\begingroup$ Windows 7 64-bit. I've looked through the whole list of commands under File> User Preferences> Input> 3D View> Mesh, and "Loop Cut and Slide" isn't listed at all. I looked through the rest of the 3D view section, and didn't find it there either. $\endgroup$ – APant1 Apr 24 '15 at 19:14
  • $\begingroup$ @APant1 did you reset to factory settings? $\endgroup$ – gandalf3 Apr 24 '15 at 19:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.