5
$\begingroup$

enter image description hereSo I am still very new to Blender, having only been working with it for about a week, but I am at the point where I am trying to get lighting set up for a Minecraft animation that I'm making for my channel but I can't get light to show up indoors. I can see through the windows but light won't pass through the windows nor will any lamps work that are placed inside. Can someone help me figure out how to fix this?

$\endgroup$
  • $\begingroup$ Can you add a screenshot? $\endgroup$ – Denis Apr 24 '15 at 5:11
  • $\begingroup$ I am using Blender Render $\endgroup$ – Ryan Shackelford Shackles Apr 24 '15 at 6:02
  • $\begingroup$ you may have to upload the .blend to PasteAll.org and paste the link here. Then again, maybe someone will recognize the problem without seeing the setup. :) $\endgroup$ – MarcClintDion Apr 24 '15 at 16:13
  • $\begingroup$ That website won't let me upload my file @MarcClintDion $\endgroup$ – Ryan Shackelford Shackles Apr 24 '15 at 17:53
  • $\begingroup$ too big? You can always make a duplicate of the file and delete most of the models and textures. Only a small portion should be needed to diagnose the issue. $\endgroup$ – MarcClintDion Apr 24 '15 at 18:15
3
$\begingroup$

The calculation of transparent shadows is a little bit slow, so the casting of transparent shadows (behind your glass) is deactivated in the default settings. To get the shadows or better the light you have to activate Receive Transparent in the Shadow-Settings in the material tab for each Material, wich receive light through an object.

< activate Receive Transparent

see Shadows in the Blender Manual

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.