0
$\begingroup$

I've made some images in Krita (drawing software) with both full and semi transparency involved. I can get the full transparency to work after importing the image to Blender, but not the semitransparency.

enter image description here

Here is the image above. The light green border around the edge is what I want to be semi transparent, but it isn't showing up correctly in Blender.

enter image description here

Here is the image in Blenders editor above. Here the light green border barely shows at all. Last but not least:

enter image description here

Above is the image after rendering. The light green border shows up, but isn't transparent at all. I have used the original image in other programs and I know that the semitransparency works, but I have no idea how to do it in Blender and all search results I find just tell me how to do full transparency, which I already know. Can anyone help me out?

Here is a link to my blend file https://ufile.io/qubd3gla And the first image I posted (above) is the actual picture used as the image texture.

$\endgroup$
3
  • 1
    $\begingroup$ Could you please share your file? (only the object with the image, don't forget to pack the image) $\endgroup$
    – moonboots
    Mar 19, 2023 at 18:50
  • $\begingroup$ That the light green border is barely showing in the editor has most likely the following reason: in the Material Properties under Viewport Display the Blend Mode is set to Alpha Clip. This means, it either displays fully opaque or fully transparent, nothing inbetween. The Clip Threshold value determines the transition. Let's say your green border has an alpha value of 0.5 and the threshold is set to 0.6, then it will be transparent. If the threshold is 0.4, it will be opaque. $\endgroup$ Mar 20, 2023 at 7:45
  • $\begingroup$ For the rendered image: hard to tell how transparent the green border is - since it is not fully transparent, it will be affected by lighting. The environment seems quite bright and a light color (even on a semi-transparent material) will reflect much light. Another thing is the uniform background does not provide any features that could be visible through a semi-transparent surface. Without knowing your exact material setup, the alpha channel of the image and the environment settings it is hard to tell what is the problem there - so I agree with @moonboots asking for the file. $\endgroup$ Mar 20, 2023 at 7:51

1 Answer 1

0
$\begingroup$

For the disappearing border in the Material Preview it is exactly like I said in the comments: in the Material Properties under Viewport Display, the Blend Mode is set to Alpha Clip, the Clip Threshold is set to 0.5, which means everything below this value is fully transparent, everything above is fully opaque. The alpha of the light green border has a brightness value of 0.238, so it is below the threshold and therefore fully transparent in Material Preview.

The reason it does not look transparent in Rendered View is also the one I gave in the comments. The light green border is a very bright color and can reflect very much light, even when it is semi-transparent - and you have a bright light shining on it. To this adds the fact that it is a green border over a green background which makes the transparency even harder to see.

In order to show you that there really is transparency even though you don't see it, I reduced the bright area light a lot and also made the background color red and even applied red emission to it. Now you get an idea that there is transparency:

semi-transparency

Because if I disable the Alpha channel, the result looks like this: the dark green is the same since it has been opaque before, but the light green border looks a lot different:

alpha disabled

If you want the border to be more transparent, you can for example plug a Color Ramp between the Alpha output of the image and the Alpha input of the Principled BSDF and move the black slider until it is transparent enough. Or maybe use a Map Range node to adjust the values. In the following image I'm still using the red background to make it more visible, but you should maybe adjust it on the actual background to find a suitable value:

decreased alpha

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .