0
$\begingroup$

I have downloaded an assets from blender kit addon (a carpet) and tried to apply an image texture to it. suddenly it crushed. I reopened the file, and deleted that carpet, tried another one, again - from blender kit, and same with that other one - it crushed.

After it happened with the 3rd carpet that I have downloaded - blender won't reopen at all, and keeps crushing right away on startup. I have no idea what causing it, well it did start crushing when added those carpets from blender kit but i dont know why.

I have deleted the image texture from the computer, believing it may somehow help, but nothing helped and still won't open. is there any way I can delete that object from command or something?

Update: Now it wont even submit the crush error. will just quit.

$\endgroup$
1
  • 1
    $\begingroup$ Try figuring out what Blender version was used to create the asset. It might be that something was changed with newer Blender versions about something like hair or geometry nodes if they are used in the asset and you are experiencing compatibility issues. Else than that, update GPU drivers and if that does not help, report a bug to the addon's developers. There is not much that can be done about bugs here - no BSE answer will fix a bug. $\endgroup$ Mar 17, 2023 at 14:47

1 Answer 1

2
$\begingroup$

For saving your file: Open an autosave. If your Blend is crashing on startup, open a new project and navigate to the autosave panel in the top left (pictured below). Blender has a pretty solid autosave system, and that should let you recover your file pre-addition of the problematic object. If you can't even open Blender at all, you should be able to manually navigate to wherever your auto-save normally is. When in doubt, search in your file manager.

For the object itself: My immediate assumption is something wonky with it's normal's or sub count causing it to drastically overcalculate something; if your determined to use a texture of carpet, please attach the file onto here for us to see and determine what the issue might be. Autosave Location

$\endgroup$

Not the answer you're looking for? Browse other questions tagged .