I am using SheepIt to render my animation, but I have a problem with Simulation Cache.

I know that you need to include the Bake Cache folder to render in SheepIt. But the Smoke Cache I simulated is too heavy, around 1000-2000 frames, it required several GB, and SheepIt can't handle the file too large.

Is there any way to handle this problem?

  • $\begingroup$ The solution to this problem is to divide the animation into multiple parts. $\endgroup$ Mar 15, 2023 at 8:41
  • $\begingroup$ yeah, I know that dividing it into multiple parts will resolve the problem. But for 2000 frames I need to divide into 6 or 7 parts. I just want to know if there is any way to reduce the cache size ?? $\endgroup$
    – Iampoor
    Mar 15, 2023 at 9:30
  • 1
    $\begingroup$ The simplest way to reduce the cache size is to reduce the complexity of the simulation like the number of substeps. I don't think there's any lossless way easily available, because then it would be enabled by default… $\endgroup$ Mar 15, 2023 at 13:33

2 Answers 2


If you don't want to bake the simulation again (because I guess it took quite a while), there is absolutely nothing else than splitting it up.

For future bakes, you might consider the following things which influence the size of the smoke cache (the factors I mention might vary from project to project, they are just to give an idea how strong the influence can be):

  • In general the smallest cache files are achieved by the default cache settings, using:

    Format Volumes: OpenVDB

    Compression Volumes: Blosc

    Precision Volumes: Half

This format generates the smallest files compared to the other possible options in the above categories. To get them even smaller, you have to enable Adaptive Domain (which is recommended anyway to reduce simulation time).

But beware of the Is Resumable option in the Cache settings. This is a nice feature to pause simulating, see if you like the result so far and resume simulating. But enabling it also makes the smoke cache more than twice as big as without it.

There is another option which can reduce the smoke cache, and that is Dissolve. When you make the smoke disappear over time, of course there is less data to be stored.

For all other settings on the domain the rule of thumb is: increasing a value increases the smoke cache. Some just a little, some more. Timesteps Maximum/Minimum just a little, Resolution Divisions a lot. Doubling the divisions results in quadrupling the smoke voxels (but fortunately just about tripling the smoke cache size).

Also an extreme factor for the smoke cache size is enabling Noise. With the default settings, a smoke cache with noise is easily 2.5 times larger than without noise.

These are just a few examples for the Domain settings. The settings of the Flow object influence the smoke cache as well of course, like the Substeps although they are almost negligible in relation to changes in the Domain settings. Very high Surface Emission values result in generating more smoke and can be an important factor as well.

As for the Domain, the rule of thumb for the Flow object also is increasing a value usually increases the smoke cache size.

There might be other things have more or less influence on the cahce size. For example open boundaries that let the smoke leave the domain can reduce the amount of data like Dissolve, while keeping the smoke inside with closed boundaries also keeps a high amount of data.

All in all you can say, higher values create larger smoke caches and when planning on reducing the size you especially have to think about:

  • Do you really need the Resolution Divisions as high as they are?
  • Do you really need the Is Resumable option, because this is a very high factor?
  • And the other important factor, how much Noise do you really need? Do you need it at all, and if so how high does the Upres Factor or Strength need to be?
  • Enable Adaptive Domain because it can save simulation time and disk space.

The answer is very simple and I suspect you know it already. The maximum uploaded file size for SheepIt render farm is 750 MB currently as they clearly specify on their upload page and several gigabytes are more than 750 MB. So no, there is no way to handle this problem.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .