3
$\begingroup$

I am starting to use Blender to edit videos on Linux. What it's wrong if I add a movie in avi format and it only works on Windows but not on Linux? In Linux it says that file cannot be loaded. If opened by terminal, it says "not an anim: /home/matsetes/kdenlive/Minetest mod spotlight 4.avi" I am using Ubuntu latest version and I installed Blender from the repository, but I tried also compiling it. Perhaps it's a problem with some codec on Ubuntu? I am able to open these files on Ubuntu and also edit them with Kdenlive.

Thank you for all, guys =)

$\endgroup$
  • $\begingroup$ Sounds like perhaps the version of ffmpeg you have doesn't have a required codec (ffmpeg is the encoding library blender uses). See the ubuntu docs for info on installing more codecs. $\endgroup$ – gandalf3 Apr 23 '15 at 8:09
  • $\begingroup$ I have installed all the codecs that I know and that I can find. The file open with every program but not with blender $\endgroup$ – Matsetes Apr 23 '15 at 8:11
  • $\begingroup$ Hm.. Is it possible you could upload a file that exhibits this behavior? $\endgroup$ – gandalf3 Apr 23 '15 at 8:16
  • $\begingroup$ You mean one file that cannot be opened? $\endgroup$ – Matsetes Apr 23 '15 at 8:18
5
$\begingroup$

I solved, after two months from when the problem occurred. I used the irc chat and three or four forums and, of course, Google. The page that helped me a lot is https://developer.blender.org/T28790 where it says that is a problem of ffmpeg with the compiling of GCC. You can solve that downloading the precompiled version here https://builder.blender.org/download/ It doesn't work if you compile the version and also the repository one does not work.

I answered my question to help all the people that will have the same problem =)

$\endgroup$
  • $\begingroup$ Each person is only allowed to have 1 (one) account on any given StackExchange site. Duplicate accounts will be dealt with accordingly. You can always answer your own question, using the same account. $\endgroup$ – VRM Apr 23 '15 at 15:16
  • 5
    $\begingroup$ @NoviceInDisguise No, you can have as many accounts as you want and that is perfectly legitimate. However, when you start inter-voting between your accounts, then it is considered reputation fraud and "will be dealt with accordingly" $\endgroup$ – X-27 wants to Reinstate Monica Apr 23 '15 at 16:44
  • $\begingroup$ @X-27 True, very good distinction to make $\endgroup$ – VRM Apr 23 '15 at 17:02
  • $\begingroup$ Sorry, I didn't noticed that in the first one was from google and the second one with an official account, my fault... $\endgroup$ – Matsetes Apr 23 '15 at 19:46
  • 2
    $\begingroup$ "It doesn't work if you compile the version and also the repository one does not work." --- This isn't true, Of course you can compile working builds with ffmpeg, otherwise - how would we do our releases? You just have to make sure you have the right ffmpeg package and enable ffmpeg in the build option. (See own answer) $\endgroup$ – ideasman42 Aug 20 '15 at 22:50
3
$\begingroup$

If you're building from source make sure the CMake option WITH_CODEC_FFMPEG is enabled.

This will use your system's ffmpeg library. Supporting codec's its built with.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.