0
$\begingroup$

I'm rendering a scene in Blender, and for some reason, the rendered image section is different from the exported image. Note the difference in the wood colour appearance in the sun.

Rendered view Rendered image view

Saved image Image

Colour settings

Colour management

$\endgroup$

1 Answer 1

0
$\begingroup$

No answer as yet, so, here is my best guess:

In the top-right of the 3D Viewport, make sure to select the correct shading option, then click the menu icon to get the viewport shading options:

Viewport Shading options

If you are not using the scene world or lights that could be an issue.

Next, in the Outliner, click the visibility filter dropdown.

Outliner visibility filter

That one between the eyeball (visible in 3D Viewport) and the camera (Renders) is the option to preview render in the viewport. Select it and check to make sure all your lights are enabled. (I don’t think it likely you have anything disabled here, but might as well check.)

Finally, you just need to look through your Scene Properties and World Properties to make sure everything is correct, alas.

I may be wrong on all counts, but these are the first things I’d check.

$\endgroup$
1
  • $\begingroup$ Everything is configured correctly, according to what you're suggesting. And, as of the sun, it's the Nishita sky texture. The problem could be due to weird colour space stuff... $\endgroup$ Mar 9, 2023 at 6:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .