1
$\begingroup$

Sorry if this is a stupid question. Running Blender 3.4.1 (same issue with experimental 3.6)

Assumption: Selecting a set of vertices (more than 3) and pressing F should generally create a face. This is what I thought. (Most often it works, but not always. This is the problem.)

Case: Creating two cubes, placing them exactly on top of each other. Then dragging one cube a little along (say Y axis) to offset it. Then selecting both cubes and ctrl-J to join (I hope the picture indicates my intention.) I have now created a mesh with intersecting faces, I know. The 3D print tool informs of this.

So I attempt to manually fix this by deleting each offending face and recreate it. Thus I start by removing one face (see figure) then selecting all 5 vertices involved and pressing F. A face appears, but alas, it does not connect to all five vertices, only four (will not stick to the one pointed to by the red arrow). This is what I do not understand. Cubes with removed face ready for face recreation

If I remove all offending faces first and then recreate them, everything works fine. It seems that I cannot do it one by one face.

(And no, I have no vertices on top of each other.)

Could anyone shed som light on why this is so? Bug of feature? (Or just me failing to understand something obvious?)

$\endgroup$

1 Answer 1

0
$\begingroup$

Well, the fifth vertex the arrow is pointing at is not connected to the edge between the vertex to the left and right. The shortcut F is for the Fill tool, so it fills the hole between the four connected vertices. Although F can create edges between unconnected vertices, in this case it simply fills the hole and ignores the single vertex.

What you can do in this case to merge the two unconnected cube meshes: enable the Auto Merge function and also Split Edges & Faces in the Options.

enter image description here

If you now select all vertices, hit G to move and directly enter 0, Return to make sure they don't move at all (do not abort the movement with right-click!), the mesh gets split and merged where the vertices and edges are touching. If you now select the five vertices and hit F, the new face is connected to all of them.

$\endgroup$
2
  • $\begingroup$ I believed I would have to fix this face by face... In fact - using Auto Merge and Split Edges & Faces - it appears I can select all and move by zero (as you suggested), and that will fix everything in one single step. Brilliant! Thanks a lot! $\endgroup$
    – JoNoS
    Mar 7, 2023 at 12:53
  • $\begingroup$ @JoNoS In this case it does, sometimes when the edges are not so well aligned it might not work as good. Of course there's still a chance by changing the Threshold value to something higher, but you have keep in mind that when a vertex is too far away for example and you change the threshold to merge it nevertheless, this might result in changing the geometry quite a bit, since the parts will be merged at their median point and this can result in faces no longer being planar etc. $\endgroup$ Mar 7, 2023 at 12:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .