1
$\begingroup$

I'm new to using Blender to make models, and wanted to make a custom VRChat model as a test of skills and even if I have the capacity to upload a model (and be Quest viable). I've watched dozens of tutorials but just can't seem to understand how this works.

So, I rig up my bones and try to scale them and move them around to match proportions. (I used my Roblox avatar so that way I didn't have to make a custom model from scratch.)

When in default pose? It works just fine, no questions asked. perfectly normal roblox avatar, nothing to see here

But the very MINUTE I try to rotate any bone in any direction... a not so normal roblox avatar, warped and skewed

I have a vague idea on how this happened, but I need a fix.

When I was making the bones, I messed with the scaling to get the proper height and width of the avatar, so that may have messed something up.

But now I need serious help trying to find a way to reverse the weird bone scaling. Maybe that'll fix the issue.

Please, if you can, try to help me with this. I'm completely lost and already spent 3 hours watching tutorials for THIS to happen, and I don't want to undo everything (but will as a last resort.)

Thank you SO much in advance.

$\endgroup$
1
  • 1
    $\begingroup$ Apply the scale in Object mode (Ctrl A > Scale). If you need to scale the bones, do it in Edit mode, not Object mode $\endgroup$
    – moonboots
    Mar 7, 2023 at 6:52

1 Answer 1

1
$\begingroup$

Most likely, you are right about "messed with scaling". Eventually, you need to apply the scale (or all transforms) of your mesh, because a child object (your mesh) will inherit all transforms of the parent mesh (your Armature) on top of its own transforms. As long as the base mesh has "zero shift", this is normally a good thing (makes your rig work), but with different scalings etc., things get a little weird:

Apply Mesh Scale

But wait! To avoid further problems, it might be good to "reset" the Rig by:

1.) either clearing the parent-child relation of the Armature... Then apply Scale, then re-parent:

Clear Parent

2.) Or you could try to temporarily disable the Armature Modifier, then Apply Scale (Quicker way, and non-destructive... Not sure if this really works, though)

Disable Armature

Let us know if this solved your Problem. If not, please add the .blend file to your Question so we can look into it further.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .