1
$\begingroup$

enter image description here

For some reason my environment texture isn't showing in my object. No matter what photo I put its always just a shade of white no matter how dark the photo I put in is. It never reflects the photo that's been input.

$\endgroup$
1
  • $\begingroup$ Could you please pack your image (FIle > External Data > Pack Resources) and share your file? blend-exchange.com or workupload and share the link $\endgroup$
    – moonboots
    Mar 7, 2023 at 6:50

1 Answer 1

1
$\begingroup$

Not sure where your reflections should come from...

1.) If the Photo named "Empty" in your Outliner is the object that should be reflected, it never will reflect anything, because it is only an Empty. These are (afaik) only used as reference images for modeling.

To get a "real" reflective Photo in your Scene, you need a textured Plane. There's a great addon inside Blender called "Import Images as Planes". You can just enable it under Edit > Preferences and see if this gives you reflections: enter image description here

2.) If the "World" should be reflected, it seems your world shader is basically set up to do this:

enter image description here

So, just get rid of the mix shader and plug your jpg straight into the background input. The image mapping, however, will be another problem. enter image description here

$\endgroup$
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .