2
$\begingroup$

so, i've worked on making an animation for a game i'm making. however, when i move the player in the animation (for my diving animation) the player's eyes make a static duplicate of themself and the first pair stays on the head, while the second pair creates a kind of "bunny ears" for the player. i've wen't in edit mode and checked if there was a second layer of eyes somehow inside of it, but there wasn't. i attached a screenshot and really would appreciate it if someone showed me how to get rid of them. thank youenter image description here

$\endgroup$
11
  • $\begingroup$ Yes you must have duplicated your eyes, maybe go in Edit mode, select all and Merge by Distance? $\endgroup$
    – moonboots
    Mar 5, 2023 at 14:08
  • $\begingroup$ @moonboots what value? $\endgroup$
    – ninjialttv
    Mar 5, 2023 at 18:28
  • $\begingroup$ Select all in Edit mode and press M > Merge by Distance $\endgroup$
    – moonboots
    Mar 5, 2023 at 18:34
  • $\begingroup$ @moonboots yea, which value do i set the "distance" number to or leave it as default bc default doesnt fix anything $\endgroup$
    – ninjialttv
    Mar 5, 2023 at 18:36
  • $\begingroup$ the value is the merge threshold, maybe increase to see if it gives something, if it doesn't fix your problem could you please share your file? $\endgroup$
    – moonboots
    Mar 5, 2023 at 18:38

1 Answer 1

2
$\begingroup$

You have a duplication of your eye mesh on the other side of your mirror axis, select it with L and delete (by the way your character is upside down):

enter image description here

Now assign the remaining eyes to the good vertex group:

enter image description here

To bring back the armature to its default rotation, rotate it 180° on Y and apply the rotation and scale (CtrlA). To bring back the armature to its rest pose, switch to Pose mode and AltR, AltG, AltS. Also put the Subdivision Surface modifier at the bottom of the modifiers stack, and enable the Preserve Volume option of the Armature modifier.

$\endgroup$
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .