2
$\begingroup$

How can I change the preview FPS (the animation rate when pressing Alt+A or Play) in Blender 2.72?

It seems locked to 30 fps, so somewhere there is an option that says 30, but I've looked everywhere and can't find it. The scene is extremely simple so not locked by performance reasons.

This other question asks the same thing:

Is it possible to adjust the frame rate of viewport playback?

and the answer there was to change the rate in the Scene tab under Dimensions, but that is 24 fps currently and changing it doesn't change the preview rate.

I don't want to render and playback etc, I just want to play the animation faster in the preview window.

Thanks!

$\endgroup$
  • 1
    $\begingroup$ Changing the rate in the Scene tab under Dimensions changes the Preview rate for me, just like it's said in the answer you've linked. $\endgroup$ – Mr Zak Apr 21 '15 at 17:28
  • $\begingroup$ very strange, some kind of sync problem between the viewports maybe or animation timeline? maybe you have to have the right animation timeline/editor open at the time you change the framerate under the Scene tab :) I'll go try some more.... $\endgroup$ – BjornW Apr 21 '15 at 17:45
2
$\begingroup$

Ok, after some more digging, I found this:

The scene tab does change the FPS, but there is some lock at 30 fps preview rate (at least on my setup) because the FPS indicator goes "red" at exactly 29.97 fps or so. It's most probably not due to scene complexity and the value is too close to 30 fps exactly to be a coincidence. Some kind of vertical sync issue?

To increase the rate anyway, the "Time Remapping" box just underneath the Frame rate box can be used, for example setting it to 100:50 will in effect make the animation twice the speed.

HOWEVER there is a bug (in 2.72) it seems that makes this time remapping not work completely smooth - the "remapped" frame numbers are shown inside the Timeline and Action editor, but the "unmapped" frame numbers are (of course) used for the keyframes (since these are not actually changed by the setting).

So, for example, if you have a 100 frames long animation setup, and you set the remapping to 100:50, you will need to change the start and end frame in the timeline to 0 and 50, or it will not loop correctly. This will show only half the range of your keyframes, since the "display frames" are now remapped compared to the "animation frames"... :/

I can post a screenshot of this if needed but it works for me (don't know if there are any hidden problems other than a display issue).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.